Меню

Скопировать настройку скд отчета



Сохранение настроек варианта отчета во внешний файл

Настройка системы 31.10.2017 09:53 13681

Вариант отчета содержит состав и настройки выводимых данных. Настройки варианта можно сохранить во внешний файл или загрузить из файла. Данная возможность позволяет легко переносить настройки из одной информационной базы в другую. Настройки отчетов сохраняются в файл с расширением (*.xml).

Сохранение настроек варианта отчета в обычном приложении

В обычном приложении варианты отчетов хранятся в специальном справочнике «Сохраненные настройки» или «Варианты отчетов». Наименование справочника зависит от вида типовой конфигурации.

Например, в «Бухгалтерия предприятия 2.0» варианты отчетов находятся в справочнике «Сохраненные настройки», в который можно попасть через главное меню: Операции->Справочники. ->Сохраненные настройки.

Сохранение настроек варианта отчета в управляемом приложении

В управляемом приложении варианты отчета сохраняются в специальное хранилище «ХранилищеВариантовОтчетов». Для того чтобы выгрузить вариант отчета во внешний файл нужно открыть отчет и перейти:
Все действия->Прочее->Изменить вариант отчета.

Все действия->Сохранить настройки

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

Источник

Как сохранить/восстановить настройки схемы и вариант схемы СКД?

sem_wolf Вопрос-ответ Ваш отзыв В закладки

Платформа 8.2 , обычное приложение. В отчете есть несколько схем СКД, на форме отчета в списке выбора пользователь сам выбирает нужную схему, помогите разобраться как сохранять/воостанавливать настройки схемы вместе с вариантом отчета. Настройки сохраняю в РС.СохраненныеНастройки. Проблема в том что я не понимаю как сохранить настройки СКД и значения реквизитов отчета вместе , получается только либо первое либо второе.

//Заполнение вариантов отчета

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Варианты = Новый СписокЗначений;
Макеты = ЭтотОбъект.Метаданные().Макеты;
Для Каждого Схема ИЗ Макеты Цикл
Варианты.Добавить(Схема.Имя,Схема.Синоним);
КонецЦикла;
ЭлементыФормы.СписокВариантов.СписокВыбора = Варианты;
КонецПроцедуры

//выбор варианта отчета

Процедура СписокВариантовПриИзменении(Элемент)
СхемаКомпоновкиДанных = ЭтотОбъект.ПолучитьМакет(Элемент.Значение);
КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
КонецПроцедуры

Процедура ПриОткрытии()
СтруктураНастройки = Новый Структура;
СтруктураНастройки.Вставить(“Пользователь”, глЗначениеПеременной(“глТекущийПользователь”));
СтруктураНастройки.Вставить(“ИмяОбъекта”, Строка(ЭтотОбъект));

Если УниверсальныеМеханизмы.ПолучитьНастройкуИспользоватьПриОткрытии(СтруктураНастройки) Тогда
мТекущаяНастройка = СтруктураНастройки;
КомпоновщикНастроек.ЗагрузитьНастройки(мТекущаяНастройка.СохраненнаяНастройка.Получить());
КонецЕсли;
КонецПроцедуры

//переопределение стандартных кн Сохранить/Восстановить значения

Процедура СохранитьНастройки() Экспорт
Перем СохраненнаяНастройка;

Если мТекущаяНастройка<>Неопределено Тогда
СтруктураНастройки = мТекущаяНастройка;
Иначе
СтруктураНастройки = Новый Структура;
СтруктураНастройки.Вставить(“ИмяОбъекта”, Строка(ЭтотОбъект));
СтруктураНастройки.Вставить(“НаименованиеНастройки”, Неопределено);
СтруктураНастройки.Вставить(“ИспользоватьПриОткрытии”, Ложь);
СтруктураНастройки.Вставить(“СохранятьАвтоматически”, Ложь);
КонецЕсли;
СтруктураНастройки.Вставить(“Пользователь”, глЗначениеПеременной(“глТекущийПользователь”));
СохраненнаяНастройка = Новый ХранилищеЗначения(КомпоновщикНастроек.ПолучитьНастройки());
СтруктураНастройки.Вставить(“СохраненнаяНастройка”, СохраненнаяНастройка);

Если ВозвращаемаяСтруктура <> Неопределено Тогда
мТекущаяНастройка = ВозвращаемаяСтруктура;
Иначе
мТекущаяНастройка = СтруктураНастройки;
КонецЕсли;

Процедура ВосстановитьНастройки() Экспорт

СтруктураНастройки = Новый Структура;
СтруктураНастройки.Вставить(“Пользователь”, глЗначениеПеременной(“глТекущийПользователь”));
СтруктураНастройки.Вставить(“ИмяОбъекта”, Строка(ЭтотОбъект));
СтруктураНастройки.Вставить(“НаименованиеНастройки”, ?(мТекущаяНастройка = Неопределено, Неопределено, мТекущаяНастройка.НаименованиеНастройки));

Если ВозвращаемаяСтруктура <> Неопределено Тогда
мТекущаяНастройка = ВозвращаемаяСтруктура;
КомпоновщикНастроек.ЗагрузитьНастройки(мТекущаяНастройка.СохраненнаяНастройка.Получить());
КонецЕсли;
КонецПроцедуры

Источник

Заметки по 1С:Предприятие 8.2, 8.3

Большинство хороших программистов делают свою работу не потому, что ожидают оплаты или признания, а потому что получают удовольствие от программирования (Linus Torvalds).

Читайте также:  Настройка аутлука 2007 учетная запись

Страницы

суббота, 21 декабря 2013 г.

Сохранение/восстановление отборов СКД в регистр «Сохраненные настройки»

Перем СКД ;
Перем мТекущаяНастройка ;

Процедура КнопкаВыполнитьНажатие ( Кнопка )

Продажи . Загрузить ( РезультатКомпоновкиВТЗ ( СКД , КомпоновщикНастроек ));

Процедура ПередОткрытием ( Отказ , СтандартнаяОбработка )

СохраненнаяНастройка = ?( ЗначениеЗаполнено ( НастройкаОтбора ), ЗначениеИзСтрокиВнутр ( НастройкаОтбора ),Неопределено);

КомпоновщикНастроек . Инициализировать (Новый ИсточникДоступныхНастроекКомпоновкиДанных ( СКД ));
Настройки = ?(НЕ СохраненнаяНастройка = Неопределено, СохраненнаяНастройка , СКД . НастройкиПоУмолчанию );
КомпоновщикНастроек . ЗагрузитьНастройки ( Настройки );

// Процедура восстановления сохраненных настроек
//
Процедура ВосстановитьНастройки () Экспорт

СтруктураНастройки = Новый Структура ;
СтруктураНастройки . Вставить ( «Пользователь» , глЗначениеПеременной ( «глТекущийПользователь» ));
СтруктураНастройки . Вставить ( «ИмяОбъекта» , Строка ( ЭтотОбъект ));
СтруктураНастройки . Вставить ( «НаименованиеНастройки» , ?( мТекущаяНастройка = Неопределено, Неопределено, мТекущаяНастройка . НаименованиеНастройки ));

Результат = УниверсальныеМеханизмы . ВосстановлениеНастроек ( СтруктураНастройки );

Если Результат <> Неопределено Тогда

мТекущаяНастройка = Результат ;
ВосстановитьНастройкиИзСтруктуры ( Результат . СохраненнаяНастройка );

// Процедура сохранения настроек
//
Процедура СохранитьНастройки () Экспорт

СтруктураНастройки = Новый Структура ;
СтруктураНастройки . Вставить ( «Пользователь» , глЗначениеПеременной ( «глТекущийПользователь» ));
СтруктураНастройки . Вставить ( «ИмяОбъекта» , Строка ( ЭтотОбъект ));
СтруктураНастройки . Вставить ( «НаименованиеНастройки» , ?( мТекущаяНастройка = Неопределено, Неопределено, мТекущаяНастройка . НаименованиеНастройки ));
СтруктураНастройки . Вставить ( «СохраненнаяНастройка» , СохраненнаяНастройка );
СтруктураНастройки . Вставить ( «ИспользоватьПриОткрытии» , Ложь);
СтруктураНастройки . Вставить ( «СохранятьАвтоматически» , Ложь);

Результат = УниверсальныеМеханизмы . СохранениеНастроек ( СтруктураНастройки );

Если Результат <> Неопределено Тогда
мТекущаяНастройка = Результат ;
Иначе
мТекущаяНастройка = СтруктураНастройки ;
КонецЕсли;

// Процедура восстановления значений реквизитов
//
Процедура ВосстановитьНастройкиИзСтруктуры ( СтруктураСНастройками ) Экспорт

Если ТипЗнч ( СтруктураСНастройками ) <> Тип ( «Структура» ) Тогда
Возврат;
КонецЕсли;

ЗаполнитьЗначенияСвойств ( ЭтотОбъект , СтруктураСНастройками );
ЗагрузитьНастройкуОтбора ();

// Процедура сохранения значений реквизитов
//
Процедура СформироватьСтруктуруДляСохраненияНастроек ( СтруктураСНастройками ) Экспорт

Если ТипЗнч ( СтруктураСНастройками ) <> Тип ( «Структура» ) Тогда
СтруктураСНастройками = Новый Структура ;
КонецЕсли;

СтруктураСНастройками . Вставить ( «НастройкаОтбора» , ЗначениеВСтрокуВнутр ( КомпоновщикНастроек . Настройки ));
СтруктураСНастройками . Вставить ( «НачалоПериода» , НачалоПериода );
СтруктураСНастройками . Вставить ( «КонецПериода» , КонецПериода );

Процедура ДействияФормыСохранитьНастройки ( Кнопка )

Процедура ДействияФормыВосстановитьНастройки ( Кнопка )

СКД = ПолучитьМакет ( «ПродажиЗаПериод» );

Функция РезультатКомпоновкиВТЗ ( СКД , КомпоновщикНастроек ) Экспорт

НастройкиКомпоновщика = КомпоновщикНастроек . Настройки ;
ПараметрыНастройки = НастройкиКомпоновщика . ПараметрыДанных ;

// устанавливаем параметры отчета
ЗначениеПараметра = ПараметрыНастройки . НайтиЗначениеПараметра (Новый ПараметрКомпоновкиДанных ( «НачалоПериода» ));
ЗначениеПараметра . Значение = НачалоПериода ;

ЗначениеПараметра = ПараметрыНастройки . НайтиЗначениеПараметра (Новый ПараметрКомпоновкиДанных ( «КонецПериода» ));
ЗначениеПараметра . Значение = КонецДня ( КонецПериода );

КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных ;
МакетКомпоновкиДанных = КомпоновщикМакета . Выполнить ( СКД , НастройкиКомпоновщика . Тип ( «ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений» ));

ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных ;
ПроцессорКомпоновкиДанных . Инициализировать ( МакетКомпоновкиДанных );

ТаблицаРезультат = Новый ТаблицаЗначений ;
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений ;

ПроцессорВывода . УстановитьОбъект ( ТаблицаРезультат );
ПроцессорВывода . Вывести ( ПроцессорКомпоновкиДанных );

6) После запуска обработки можно установить параметры: начало и конец периода, а также определить отбор. Потом сохранить настройку. При последующей работе можно вернуться к этой настройке нажав кнопку восстановления настроек. Как это сделать показано на скриншоте.
Пример обработки можно скачать ЗДЕСЬ.

Источник

Ваш браузер устарел, пожалуйста обновите ваш браузер пройдя по ссылке www.microsoft.com/download

Вместо предисловия

Данную обработку пришлось написать при объединении баз двух организаций. Пришлось переносить часть внешних отчетов из одной базы в другую, а поскольку большая часть отчетов была написана на шаблоне типового отчета, то вместе с отчетами пришлось переносить и их настройки

Читайте также:  Тонкая настройка гбо брс

Порядок работы

В базе-источнике запускаем эту обработку и выполняем действия на вкладке Выгрузка настроек

Отмечаем настройки каких отчетов необходимо сохранить в файл. Для этого

Если необходимо перенести некоторые варианты отчетов, ставим галку «Выгрузить отдельные элементы» и в правом поле выполняем побор вариантов отчетов из всего списка(Кнопка Подбор) или подбор из вариантов конкретного отчета (кнопка Подбор настроек по отчету)

Если необходимо перенести все варианты отчетов, ставим галку «Настройки внешних отчетов» и с помощью кнопки Подбор подбираем отчеты, все варианты которых надо перенести

В поле Имя файла указываем в какой xml-файл надо сохранить настройки

Жмем внопку Выполнить. При этом настройки отчетов будут сохранены в xml-файл в формате универсального обмена данными

Переходим в базу-приемник. Запускаем эту обработку там и переходим на вкладку Загрузка настроек

В поле ниже указываем для каких групп пользователей будут даны права сохранения загруженных настроек

В поле Имя файла указываем из какого xml-файл надо загрузить настройки

Жмем кнопку Выполнить

Выполнено с использованием конфигурации Конвертация данных 2.

Недостатки

Медленно открывается, т.к. загружаются правила обмена.

Источник

Скопировать настройку скд отчета

Войдите как ученик, чтобы получить доступ к материалам школы

Система компоновки данных 1С 8.3 для начинающих: меняем созданный отчет

Автор уроков и преподаватель школы: Владимир Милькин

На этом уроке мы научимся менять уже созданный на основе СКД отчёт.

Ставим цель

Целью этого урока будет:

    Скопировать файл отчёта с прошлого урока «Урок1.erf». Изменить имя скопированного отчёта на «Урок2.erf». Открыть отчёт «Урок2.erf» в конфигураторе. Внести изменения в схему компоновки данных.

Создаём копию отчёта с предыдущего урока

Вначале копируем отчёт предыдущего урока.

. и вставляем его на рабочий стол:

Далее переименовываем получившуюся копию.

Открываем копию в конфигураторе

Открываем базу «Гастроном» в конфигураторе:

Открываем в конфигураторе отчёт .

В открывшейся форме отчёта меняем имя на «Урок 2» и нажимаем кнопку «Открыть схему компоновки данных»:

Вот она наша схема — в том виде как мы её настроили на прошлом уроке:

Меняем заголовки столбцов

Вы помните как выглядит этот отчёт в режиме пользователя? Вот так:

Читайте также:  Настройка групп пользователей в active directory

Давайте изменим нашу схему так, чтобы вместо «Наименование» выводилось «Имя», а вместо «Пол» выводилось «М/Ж».

Сделать это проще простого.

В схеме на закладке «Наборы данных» в области «Поля» устанавливаем галку и меняем заголовок соответствующих полей:

Сохраняем наш отчёт нажатием на значок дискета:

И вновь открываем его в режиме пользователя (при этом не забудьте закрыть предыдущий отчет) и нажимаем кнопку «Сформировать»:

Заголовки колонок изменились нужным образом. Отлично

Меняем порядок столбцов

Для этого возвращаемся в конфигуратор (вообще не нужно было его закрывать) в нашу схему компоновки данных и переходим на закладку «Настройки».

Выделив «Отчет» переходим (ниже) на закладку «Выбранные поля», выделяем там поле «Наименование» и при помощи стрелки перемещаем его наверх:

Получилось вот так:

Аналогичным образом меняем порядок оставшихся полей, чтобы получилось вот так:

Вновь сохраняем отчёт и, не закрывая конфигуратора, открываем и формируем его в режиме пользователя:

Всё получилось. Порядок колонок теперь вполне логичный.

Меняем оформление и добавляем заголовок

Для этого в режиме конфигуратора переходим на закладку «Настройки», обязательно выделяем «Отчет», далее в самом низу переходим на закладку «Другие настройки» и нажимаем на кнопку выбора для пункта «Макет оформления»:

Выбираем вместо основного вариант «Античный»:

Теперь давайте добьёмся того, чтобы у нас в отчёте перед таблицей выводился заголовок «Наши клиенты».

Чтобы это сделать проматываем список других настроек вниз и устанавливаем поля «Выводить заголовок» и «Заголовок» как на рисунке ниже:

Сохраняем отчёт и открываем его в режиме пользователя:

Видим, что появился заголовок и изменилось оформление.

Меняем сортировку

Для этого сделаем сортировку полю «Пол».

Снова возвращаемся к конфигуратору. Переходим на закладку «Настройки», выделяем «Отчет» и переходим на закладку (в самом низу) «Сортировка».

Там перетаскиваем поле «Пол» из первой колонки во вторую:

А также указываем для него направление сортировки «По убыванию»:

Сохраняем отчёт, а затем формируем его в режиме пользователя:

Отлично, строки в отчёте отсортированы по полу: вначале идут женщины, а затем мужчины.

Войдите на сайт как ученик

Авторизуйтесь, чтобы получить доступ ко всем материалам школы

Прибегайте к изучению эталонного варианта только после самостоятельного выполнения всех шагов.

На вопросы учеников — отвечаю по почте, но прежде загляните в ЧАВО (ссылка) .

Войдите как ученик, чтобы получить доступ к материалам школы

№2: меняем созданный отчет

№4: меняем оформление

№5: делаем отбор и сортировку на уровне СКД

Источник

Adblock
detector