Меню

Ospf cisco linux настройка



Урок 31. Настройка протокола OSPF на маршрутизаторе Cisco

Необходимые команды для начала работы протокола

Попробуем настроить сеть ниже

Сеть состоит из магистральной и 2-х стандартных зон.

Для запуска OSPF достаточно выполнить следующие команды:

Router(config)# router ospf номер_процесса

Router(config-router)# network IP_адрес инверсная_маска (Wildcard mask) area номер_зоны

Router(config-router)# network IP_адрес маска (Wildcard mask) area номер_зоны

Например, вот так выглядят настройки маршрутизатора F стандартной зоны:

А вот так выглядят настройки ABR маршрутизатора (маршрутизатор С):

Что означает номер процесса?

Это означает, что на маршрутизаторе могут быть запущены несколько независимых друг от друга OSPF процессов. Причем каждый процесс строит свою собственную базу данных. Номер процесса играет исключительно локальное значение и может не совпадать с номером процесса на других маршрутизаторах.

А что означает инверсная маска?

Инверсная маска (обратная маска) используется для более гибкого управления объявления подсетей в анонсах LSA, например когда требуется включить в анонсы LSA первые 8 или последние 64 подсетей определенной сети — вариантов много. Без инверсной маски пришлось бы вводить много похожих команд вручную. В OSPF данный функционал используется редко, однако мы рассмотрим его подробно в уроке по спискам доступа (Access Lists, ACL).

Поэтому для настройки OSPF вместо обратной маски можно с успехом использовать обычную маску. В дальнейшем мы рассмотрим пару примеров настройки OSPF с обратной маской.

Команды просмотра настроек протокола

Для проверки и диагностики работы протокола можно воспользоваться приведенными ниже командами.

Router# show ip route

Настройки протокола, адреса подключенных соседей, номер и тип зоны, а также ID локального маршрутизатора можно узнать из следующих 2-х команд:

Router# show ip protocols

Router# show ip ospf номер процесса

Топологическая база данных:

Router# show ip ospf database

Тип сети, DR/BDR, ID маршрутизатора:

Router# ip ospf interface

Таблица соседей и состояние смежности, установленные с ними:

Router# show ip ospf neighbor

Для управления выбором DR/BDR можно настроить Router ID:

Router(config-router)# router-id ID в формате IP адреса

Того же можно добиться с помощью настройки интерфейса обратной петли Loopback

Можно также повлиять на выбор маршрута, то есть заранее предопределить какой какой маршрут будет иметь лучшую/худшую метрику. Например, может возникнуть ситуация, когда до сети назначения ведут сразу 2 и более маршрутов с одинаковыми метриками. Однако по ряду причин требуется использовать только определенный маршрут, а остальные оставить в резерве. Это достигается 3-мя способами.

1) Изменение стоимости интерфейса. Вернемся к нашей сети и выполни команды

Router# show ip ospf interface

Router# show ip route

и обрати внимание на установленную стоимость интерфейса и метрику маршрута

Теперь изменим стоимость интерфейса с помощью команды

Router_B(config-if)# ip ospf cost 50

И посмотрим снова на вывод команд

Читайте также:  Настройка режима вывода звука

2) Изменение полосы пропускания . Стоимость маршрута рассчитывается по формуле исходная полоса пропускания/полоса пропускания интерфейса . За исходную полосу пропускания берется 100 Мбит/с. Полоса пропускания интерфейса уже по умолчанию установлена. Например, Ethernet — 10 Мбит/с, FastEthernet — 100 Мбит/с. Значение данного параметра можно изменить, однако это не повлияет на фактическую полосу пропускания интерфейса

Router(config-if)# bandwidth значение

3) Изменение исходной полосы пропускания . В вышеупомянутой формуле можно также изменить и числитель, то есть исходную полосу пропускания

Router(config-router)# auto-cost reference-bandwidth значение

OSPF поддерживает аутентификацию паролем открытого текста и хэшем MD5.

Аутентификацию можно включить глобально для всего процесса OSPF либо на отдельном интерфейсе.

Аутентификация на отдельном интерфейсе:

1) Пароль открытым текстом

Router(config-if)# ip ospf authentication

Router(config-if)# ip ospf authentication-key пароль

2) С помощью MD5

Router(config-if)# ip ospf authentication message-digest

Router(config-if)# ip ospf message-digest-key номер ключа md5 пароль

На интерфейсе соседнего маршрутизатора (к которому подключен напрямую) должны быть идентичные настройки, то есть тип аутентификации и пароль должны совпадать, иначе оба маршрутизатора никогда не установят отношения смежности.

Глобальная настройка аутентификации:

Router(config)# router ospf номер процесса

Router(config-router)# area номер зоны authentication message-digest

Затем настроим пароли на каждом интерфейсе

Router(config-if)# ip ospf message-digest-key номер ключа md5 пароль

В этом случае аутентификация должна быть включена во всех маршрутизаторах одной зоны. Пароли на каждом интерфейсе можно использовать разные, однако они должны совпадать с паролями на соседних маршрутизаторах, подключенных напрямую.

Источник

Как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей

Рассмотрим как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей. Исследуемая топология состоит из трех маршрутизаторов Cisco 1941 с образом Cisco IOS Release 15.4 IP Base. Допускается использование маршрутизаторов других моделей, а также других версий операционной системы Cisco IOS. В зависимости от модели устройства и версии Cisco IOS доступные команды и результаты их выполнения могут отличаться от тех, которые показаны в этой статье.

Схема топологии следующая:

Сценарий

Для улучшения эффективности и масштабируемости в OSPF поддерживается иерархическая маршрутизация, использующая понятие областей. Область (area) OSPF — это группа маршрутизаторов, использующих в своих базах данных состояний каналов (LSDB) общие и одинаковые данные о состоянии каналов. Если большая область OSPF разделена на области меньшего размера, такая архитектура называется OSPF для нескольких областей. Использование OSPF для нескольких областей является целесообразным в сетях большего размера, поскольку это позволяет сократить потребление ресурсов ЦП и памяти.

В этой статье будет показана настройка сети OSPFv2 для нескольких областей с межобластными суммарными маршрутами.

Сделаем базовые настройки маршрутизаторов.

Настроим интерфейсы.

Настроим OSPF.

Также поменяем тип сети в каналах между R1 и R2, R2 и R3 на «точка-точка», чтобы не тратились ресурсы на выбор DR/BDR:

Читайте также:  Настройки на tv phone e71

Настройка межобластных суммарных маршрутов.

OSPF не выполняет автоматическое объединение. Объединение межобластных маршрутов необходимо вручную настроить на маршрутизаторах ABR. С помощью команд show можно будет наблюдать, каким образом объединение влияет на таблицу маршрутизации и базы данных LSDB.

Теперь вы знаете, как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей.

Спасибо за уделенное время на прочтение статьи о том, как настроить многозоновый OSPF!

Если возникли вопросы — задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Источник

Заметки Системного Администратора

9 июн. 2012 г.

Настройка шлюза на ОС Linux (CentOS) + OSPF, cisco, zebra, два pppoe соединения

Организовать бесперебойную работу производственной базы, офисов, IP телефонии и интернета, при условии, что один из провайдеров жив, без использования скриптов.

Реализовать данную задачу протоколом динамической маршрутизации OSPF. За переключение между pppoe соединениями будет отвечать демон zebra.

В результате, посредством ospf и zebra, мы получим динамическую маршрутизацию между точками 192.168.31.1(cisco, т.к. на нее приходит поток Е1, нам она очень важна, а так же в данной конфигурации на ней висят офисы) и 192.168.31.2(Linux, главный шлюз, за которым находится сервер IP телефонии и производственная база), а так же динамический выбор маршрута из двух подключений ppooe (ppp0 и ppp1), при чем ppp0 будет оставаться всегда приоритетным.

Под катом продолжение.

cisco2811(192.168.31.1) с потоком Е1(30 номеров) — 1шт.
elastix(192.168.31.2) — 1шт.
Шлюзов на ОС linux — 4шт.
Два провайдера, приходящих на основную базу (192.168.31.2) и циску (192.168.31.1).
Общее кол-во раб.станций

70.
IP телефонов Linksys SPA XXXX и cisco SPA — 53шт.
Серверваки с разными сервисами нам сейчас не важны.
Версия CentOS : [root@centos quagga]# cat /proc/version
Linux version 2.6.32-220.el6.x86_64 (mockbuild@c6b18n3.bsys.dev.centos.org) (gcc version 4.4.6 20110731 (Red Hat 4.4.6-3) (GCC) ) #1 SMP Tue Dec 6 19:48:22 GMT 2011

# Generated by iptables-save v1.4.7 on Wed Jun 6 05:01:19 2012
*mangle
:PREROUTING ACCEPT [86:16575]
:INPUT ACCEPT [65:15354]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [26:3584]
:POSTROUTING ACCEPT [26:3584]
COMMIT
# Completed on Wed Jun 6 05:01:19 2012
# Generated by iptables-save v1.4.7 on Wed Jun 6 05:01:19 2012
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [12:1880]
COMMIT
# Completed on Wed Jun 6 05:01:19 2012
# Generated by iptables-save v1.4.7 on Wed Jun 6 05:01:19 2012
*nat
:PREROUTING ACCEPT [45:13683]
:POSTROUTING ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A POSTROUTING -s 192.168.31.6 -o ppp+ -p all -j MASQUERADE
-A POSTROUTING -s 192.168.0.0/255.255.248.0 -o ppp+ -p tcp -m multiport —dports 25,53,80,110,143,443,995,5190 -j MASQUERADE
-A POSTROUTING -s 192.168.0.0/255.255.248.0 -o ppp+ -p udp -m multiport —dports 53 -j MASQUERADE
-A POSTROUTING -s 192.168.0.0/255.255.248.0 -o ppp+ -p icmp -j MASQUERADE
COMMIT
# Completed on Wed Jun 6 05:01:19 2012

fo 0/0 ip address 192.168.30.1/29 , 192.168.31.9/30 secondary — Провайдер 1.
fo 0/1 ip address 192.168.40.9/30 — Провайдер 2.
lo ip address 192.168.31.1/32
ip route 192.168.2.0 255.255.255.0 192.168.30.2
ip route 192.168.3.0 255.255.255.0 192.168.30.3
ip route 192.168.4.0 255.255.255.0 192.168.30.4
ip route 0.0.0.0 0.0.0.0 192.168.31.2

eth0 ip address 192.168.1.2/24
eth0.10 ip address 192.168.31.10/30
eth0.11 ip address 192.168.40.10/30
eth0.12 ip address 192.168.31.5/30
lo:0 ip address 192.168.31.2/32
ppp0
ppp1

net.ipv4.ip_forward = 1 — включаем форвординг.
net.ipv4.conf.eth0.rp_filter = 0 — отключаем rp_filter, пришлось указывать явно, ибо упрямо не хотел меняться.
net.ipv4.conf.all.rp_filter = 0
net.ipv4.conf.default.rp_filter = 0
sysctl -p — применяем/перезагружаем параметры.

DEFROUTE = no — за маршрут по умолчанию у нас будет отвечать zebra
DEMAND = no — значение ‘no’ позволяет ppp-соединению существовать неограниченно долго;
PPPD_EXTRA = «unit 0» — Устанавливает номер интерфейса ppp для исходящих соединений, unit 0 для ppp0 и unit 1 для ppp1, дабы при падении ppp0, ppp1 не изменялся на ppp0

nameserver 87.103.234.10
nameserver 87.103.234.8
nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 192.168.1.30
search mydomain.local — для поиска внутренних машин, записи зоны хранятся на 1.30, имя домена изменено, за рекламу мне никто не платит 🙂

configure terminal
router ospf 1
router-id 192.168.31.1 redistribute static subnets
network 192.168.31.1 0.0.0.0 area 1
network 192.168.30.0 0.0.0.255 area 1
network 192.168.31.8 0.0.0.3 area 1
network 192.168.40.8 0.0.0.3 area 1

QCONFDIR=»/etc/quagga»
#BGPD_OPTS=»-A 127.0.0.1 -f $/bgpd.conf»
#OSPF6D_OPTS=»-A ::1 -f $/ospf6d.conf»
OSPFD_OPTS=»-A 127.0.0.1 -f $/ospfd.conf»
#RIPD_OPTS=»-A 127.0.0.1 -f $/ripd.conf»
#RIPNGD_OPTS=»-A ::1 -f $/ripngd.conf»
ZEBRA_OPTS=»-A 127.0.0.1 -f $/zebra.conf»
#ISISD_OPTS=»-A ::1 -f $/isisd.conf»
# Watchquagga configuration (please check timer values before using):
WATCH_OPTS=»»
WATCH_DAEMONS=»zebra ospfd» #WATCH_DAEMONS=»zebra bgpd ospfd ospf6d ripd ripngd»
# To enable restarts, uncomment this line (but first be sure to edit
# the WATCH_DAEMONS line to reflect the daemons you are actually using):
#WATCH_OPTS=»-Az -b_ -r/sbin/service_%s_restart -s/sbin/service_%s_start -k/sbin/service_%s_stop

hostname centos.blablabla.local
password blablabla
enable password blablabla
!
log file /var/log/quagga/zebra.log
!
! interface description
!
interface ppp0
description Rostelecom
link-detect
!
interface ppp1
description AgencyJin
link-detect
!
ip route 0.0.0.0/0 ppp0 10
ip route 0.0.0.0/0 ppp1 200
!
interface eth0
ip address 192.168.1.2/24
!
interface eth0.10
ip address 192.168.31.10/30
!
interface eth0.11
ip address 192.168.40.10/30
!
interface eth0.12
ip address 192.168.31.5/30
!
interface lo:0
ip address 192.168.31.2/32

!
! OSPFd sample configuration file
!
!
hostname centos.primer.local
password primer
enable password superprimer
!
router ospf
ospf router-id 192.168.31.2
network 192.168.31.2/32 area 1
network 192.168.1.0/24 area 1
network 192.168.31.4/30 area 1
network 192.168.31.8/30 area 1
network 192.168.40.8/30 area 1
!
log file /var/log/quagga/ospfd.log

service zebra start
service ospfd start
chkconfig zebra on
chkconfig ospfd on

Источник

Adblock
detector