Меню

Настройка route map cisco настройка описание примеры



CISCO: IP SLA, Track, Embedded Event Manager, Route-map, два провайдера

Два провайдера и CISCO роутер

IP SLA — позволяет создавать тесты
Enhanced Object Tracking (Track) — отслеживает состояние выбранного объекта
EEM (Embedded Event Manager) — отслеживает события в логах, по возникновению исполнит заданную последовательность действий
Route-map — маршрут на основе правил

Пример (роутер и два провайдера, в случае падения изменяем основной маршрут):
!
!
interface FastEthernet0/0
description LAN
ip address 172.16.0.1 255.255.255.0
ip nat inside
ip policy route-map FastEthernet0.0-nexthop
!
interface FastEthernet0/1
description ISP1
ip address 1.1.1.2 255.255.255.252
ip nat outside
!
interface FastEthernet0/2
description ISP2
ip address 2.2.2.2 255.255.255.252
ip nat outside
!
access-list 172 permit ip 172.16.0.0 0.0.0.255 any
access-list 172 deny ip any any
!
!
ip sla 1
icmp-echo 8.8.8.8 source-interface FastEthernet0/1
threshold 1000
timeout 1500
frequency 3
!
ip sla schedule 1 life forever start-time now
!
ip sla 2
icmp-echo 8.8.8.8 source-interface FastEthernet0/2
threshold 1000
timeout 1500
frequency 3
!
ip sla schedule 2 life forever start-time now
!
!
track 1 ip sla 1 reachability
delay down 15 up 10
!
track 2 ip sla 2 reachability
delay down 15 up 10
!
!
ip route 0.0.0.0 0.0.0.0 1.1.1.1 10 track 1
ip route 0.0.0.0 0.0.0.0 2.2.2.1 20 track 2
ip route 0.0.0.0 0.0.0.0 1.1.1.1 254
!
!
route-map ISP_1 permit 10
match ip address 172
match interface FastEthernet0/1
!
route-map ISP_2 permit 10
match ip address 172
match interface FastEthernet0/2
!
route-map FastEthernet0.0-nexthop permit 10
set ip next-hop verify-availability 1.1.1.1 1 track 1
set ip next-hop verify-availability 2.1.1.1 2 track 2
!
!
event manager applet DOWN_and_UP
event track 1 state any
action 1.0 cli command «clear ip nat translation forced»
!
!
ip nat inside source route-map ISP_1 interface FastEthernet0/1 overload
ip nat inside source route-map ISP_2 interface FastEthernet0/2 overload
!

Сдесь:

Тест IP SLA (Проверка доступности google)
threshold — указания верхнего порога значения времени, timeout — задержка, frequency — частота
Рекомендация настройки параметров — «frequency seconds» больше «timeout milliseconds» больше «threshold milliseconds»
!
ip sla 1
icmp-echo 8.8.8.8 source-interface FastEthernet0/1
threshold 1000
timeout 1500
frequency 3
!
ip sla schedule 1 life forever start-time now
!
ip sla 2
icmp-echo 8.8.8.8 source-interface FastEthernet0/2
threshold 1000
timeout 1500
frequency 3
!
ip sla schedule 2 life forever start-time now
!

TRACK (связываем с нашим sla тестом, задержка срабатывания на down — 15, up — 10 секунд)
Параметр state: Up — код OK, Down — другие коды
Параметр reachability: Up — код OK или код OverThreshold, Down — другие коды
!
track 1 ip sla 1 reachability
delay down 15 up 10
!
track 2 ip sla 2 reachability
delay down 15 up 10
!

EEM событие (тест провалился — в свойствах меняем маршрут на второго провайдера)
!
event manager applet DOWN_and_UP
event track 1 state any
action 1.0 cli command «clear ip nat translation forced»
!

Route-map — управляем информацией в таблице маршрутизации на основании показаний триггеров
!
route-map FastEthernet0.0-nexthop permit 10
set ip next-hop verify-availability 1.1.1.1 1 track 1
set ip next-hop verify-availability 2.1.1.1 2 track 2
!
Тут:
set ip next-hop verify-availability 1.1.1.1 10 track 1 – устанавливает next-hop на 1.1.1.1 по значении track 1 — «up», имеет приоритет 10
set ip next-hop verify-availability 2.1.1.1 20 track 2 — устанавливает next-hop на 2.1.1.1 по значении track 2 — «up», имеет приоритет 20

Читайте также:  Настройка pdf в опере

Route-map назначаем на ВХОДЯЩИЙ интерфейс:
!
interface FastEthernet0/0
description LAN
ip address 172.16.0.1 255.255.255.0
ip nat inside
ip policy route-map FastEthernet0.0-nexthop
!

В итоге весь траффик локальной сети маршрутизируется в соответствии с route-map, контролируясь таблицей маршрутизации

Дебаг:
sh ip sla summary
sh ip sla statistics 1
sh ip sla statistics details
sh track
sh track brief
show ip nat translations

Источник

Статическая маршрутизация Cisco

Статическая маршрутизация Cisco

Всем привет сегодня мы с вами поговорим про такую вещь как статическая маршрутизация в оборудовании Cisco. Эта статья продолжение поста Как настроить маршрутизатор cisco / Организация сети для небольшого офиса. Там мы настроили локальную сеть в двух офисах компании, один маленький офис, второй чуть побольше. На роутере во втором офисе мы остановились на настройке статической маршрутизации, чем мы и займемся.

Таблица маршрутизации

Первое с чем нужно познакомиться, это с понятием таблицы маршрутизации. Если в двух словах это некая карта маршрутов, до сетей о которых знает ваш коммутатор 3 уровня или роутер. Для большей наглядности ее можно сравнить с картой дорог до городов России. И для того, чтобы например мне попасть из Москвы в Нижний Новгород, я должен выбрать определенную дорогу. Так и ваш роутер выбирает ее. Далее если мне нужно из Москвы попасть в Казань, и мне нужно ехать туда через Нижний Новгород, то В НН должен быть свой маршрут до Казани и так далее.

Статический маршрут — это постоянный неизменный маршрут, чаще всего прописанный в ручную.

Схема сети офисов

У нас есть филиал, в котором 3 компьютера коммутатор второго уровня Cisco 2960 и Роутер Cisco 1841, есть три vlan (2,3,4). Есть главный офис в котором есть 5 vlan (2,3,4,5), маршрутизацией локального трафика занимается ядро в виде коммутатора 3 уровня Cisco 3560, который VLAN 5 подключен к роутеру Cisco 2911, на котором настроен будет интернет и канал до филиала.

В предыдущем посте где мы создавали данную локальную сеть я не настроил vlan 5 на роутере и ядре, исправим это.

Настройка Cisco 2911 и Cisco 3560

Настройка Cisco 3560

Создаем Vlan 5
vlan 5
name VLAN5
exit

Настроим ip адрес VLAN5
int vlan 5
ip address 192.168.5.1 255.255.255.0
exit

Добавим порт gi1/1 в VLAN5
int gi0/1

выставляем режим доступа
switchport mode access
switchport access vlan 5
no shutdown
do wr mem

Настройка Cisco 2911

Так как у нас локальной маршрутизацией трафика занимается ядро то тут sub интерфейсов создавать не нужно. Настроим порт роутера gi0/0 на vlan5.

Читайте также:  Карбюратор к60в крот настройка

Добавление статических маршрутов на Cisco 2911

Так как наш роутер Cisco 2911 ничего не знает о сетях 192.168.1.0, 192.168.2.0, 192.168.3.0, то нужно задать ему статические маршруты до них, через ядро делается это следующим образом.

Удостоверимся что пинг не проходит до компьютера 192.168.1.1, вводим на роутере.

Видим ответов нет

Переходим в режим конфигурирования командой

и смотрим команду ip:

access-list Named access-list

cef Cisco Express Forwarding

default-gateway Specify default gateway (if not routing IP)

default-network Flags networks as candidates for default routes

dhcp Configure DHCP server and relay parameters

domain IP DNS Resolver

domain-lookup Enable IP Domain Name System hostname translation

domain-name Define the default domain name

flow-export Specify host/port to send flow statistics

forward-protocol Controls forwarding of physical and directed IP broadcasts

ftp FTP configuration commands

host Add an entry to the ip hostname table

local Specify local options

name-server Specify address of name server to use

nat NAT configuration commands

route Establish static routes

routing Enable IP routing

ssh Configure ssh options

tcp Global TCP parameters

Нам нужна команда ip route.

так как ip адрес на ядре сети (Cisco 3560) у VLAN 5 у нас 192.168.5.1 то он будет выступать для нас шлюзом. В итоге пишем.

и выполнив теперь команду Ping мы видим. что пакет дошел до 192.168.1.1

Планирование сети

Все бы хорошо, но мы не правильно спланировали сеть в удаленном офисе. Так как там как и в главном, тоже есть сеть 192.168.1.0, 192.168.2.0, 192.168.3.0, такого быть не должно иначе получается дубли. Как правильно планировать сеть я писал тут, вам нужно перенастроить, как ранее описано в предыдущей статье. В итоге в филиале я заменил сети на 11, 22, 33 третьи актеты ip адреса. Общая картина теперь выглядит так.

Соединение роутеров

Соединяем наши роутеры. Предположим, что между ними есть прямой линк, в жизни конечно это VPN канал. настроим в начале роутер Cisco 2911 в главном офисе.

маска тут 32 бита так как нам достаточно всего 2 ip адреса.

Теперь настроим роутер Cisco 1841 в филиале. У меня это интерфейс fa0/1

У нас загорелись порты обоих коммутаторов.

Проверяем пинги с роутеров друг до друга

Видим, что все успешно.

Настройка маршрутов между роутерами

Пробуем например с роутера в филиале пропинговать компьютер 192.168.1.1, и естественно пинг не пройдет так как нет маршрутов, чем мы и займемся. Так как у нас один шлюз соединения между офисами, то правильнее будет прописать один дефолтный путь, но можно и прописывать конкретный статический маршрут, например если основной шлюз интернет и весь трафик по умолчанию идет туда и вы хотите на конкретную сеть завернуть через другой шлюз.

Читайте также:  Asic miner block erupter usb настройка

но если бы нужно было прописать ручками каждый то вот так

ip route 192.168.1.0 255.255.255.0 192.168.100.1

ip route 192.168.2.0 255.255.255.0 192.168.100.1

ip route 192.168.3.0 255.255.255.0 192.168.100.1
do wr mem

Настроим теперь роутер у главного офиса, нам нужно добавить маршруты до сетей 192.168.11.0, 192.168.22.0, 192.168.33.0.

либо если нужно в ручную отдельным маршрутом.

Настройка маршрутов на ядре

Напомню, что локальный трафик маршрутизирует ядро сети коммутатор 3 уровня Cisco 3560, и на нем нужно тоже указать маршруты, до филиала. В качестве шлюза указывается, ip адрес vlan5 на роутере 2911 192.168.5.251

Вот финальный вид нашей филиальной сети.

Берем теперь компьютер из филиала с ip адресом 192.16811.1 и пробуем с него пропинговать 192.168.1.1 для примера. И видим, что все отлично пингуется, значит связь между офисами есть.

Посмотреть таблицу маршрутизации на Cisco можно командой

Где буква C означает что соединение установлено, буква S означает что маршрут статический.

Вот так вот просто объединить офисы в одну сеть, мы с вами разобрались со статической маршрутизацией, рассмотрели ее на примерах. В организации тестового стенда мне помог симулятор, Скачать Cisco packet tracer можно тут. На этом все.

Популярные Похожие записи:

9 Responses to Статическая маршрутизация Cisco

Спасибо за статью.

Помогите разобраться с маршрутизацией и настроить доступ к локальным сетям:
Есть три здания:
Здание1 IP-адрес внешний 10.135.13.129 Маска 255.255.255.128 IP-адрес внутренний 150.150.2.3 Маска 255.255.0.0

Здание 2 IP-адрес внешний 10.135.59.1 Маска 255.255.255.128 IP-адрес внутренний 192.168.30.1 Маска 255.255.255.0

Здание 3 IP-адрес внешний 10.135.67.1 Маска 255.255.255.128 IP-адрес внутренний 192.168.0.1 Маска 255.255.255.0

Ping между роутерами Cisco по внешним адресам есть

У меня вот такое предположение:

ip route 192.168.30.0 255.255.255.0 10.135.13.129

ip route 192.168.0.0 255.255.255.0 10.135.13.129

ip route 150.150.0.0 255.255.0.0 10.135.59.1

ip route 192.168.0.0 255.255.255.0 10.135.59.1

ip route 150.150.0.0 255.255.0.0 10.135.67.1

ip route 192.168.30.0 255.255.255.0 10.135.67.1

Ping к компьютерам из внутренних сетей не проходит.

а по трассировкам куда трафик идет?

Трассировка до яндекса

Трассировка маршрута к YA.ru [213.180.193.3]
с максимальным числом прыжков 30:

Хотя по логике должно быть так:

Route -p add 192.168.30.0 mask 255.255.255.0 10.135.59.1

Route -p add 192.168.0.0 mask 255.255.255.0 10.135.67.1

Route -p add 150.150.0.0 mask 255.255.0.0 10.135.13.129

Route -p add 192.168.0.0 mask 255.255.255.0 10.135.67.1

Route -p add 150.150.0.0 mask 255.255.0.0 10.135.13.129

Route -p add 192.168.30.0 mask 255.255.255.0 10.135.59.1

Нашел ошибку(мешали остатки настроек от прошлого хозяина) теперь трессеровка вот так выглядит:

Трассировка маршрута к 192.168.30.1 с максимальным числом прыжков 30

Алексей извините, что не ответил, отсутствовал по уважительной причине, сын родился 🙂 Рад, что вы нашли у себя причину проблемы.

Про маршрутизацию всё рассказали и показали, а вот доступ к Интернету, что-то упустили,хотелось бы по подробнее, или я что-то не увидел? =)

…маска тут 32 бита так как нам достаточно всего 2 ip адреса
ip address 192.168.100.1 255.255.255.252

Источник

Adblock
detector