Меню

Настройка порт ченел на cisco



Настройка порт ченел на cisco

Агрегация каналов может быть настроена вручную или при помощи двух протоколов PaGP, LACP.

PaGP (Port Aggregation Protocol ) протокол пренадлежащий компании Cisco

LACP ( Link Aggregation Protocol ) протокол который описывается стандартом
IEEE 802.3ad

Оба протокола обмениваются пакетами между объедененными интерфейсами для формирования Port-channel. Тем ни менее, если настроить агрегацию каналав в ручную, то пакетов с обновлениями отсылаться не будет.
Port-channel не будет работать, если с одной стороны он будет настроин вручную, а с другой стороны будет настроин PaGP или LACP.

Настройка Port-channel вручную:
Switch(config)# interface range fa0/23 — 24
Switch(config-if)# channel-group 1 mode on

Порты Коммутатора с другой стороны должны быть настроины таким же образом.
Channel-group ( номер ) обозначает номер этого Port-channel. Он не должен быть идентичным с обоих сторон. Количество агрегированных каналов на коммутаторах ограничено.

Настроим коммутатор номер 1
Switch(config)# interface range fa0/23 – 24
Switch(config-if)# channel-protocol pagp
Switch(config-if)# channel-group 1 mode desirable

Настроим коммутатор номер 2
Switch(config)# interface range fa0/23 – 24
Switch(config-if)# channel-protocol pagp
Switch(config-if)# channel-group 1 mode auto

На портах обоих коммутаторав должен быть настрое протокол PaGP.
Существует два варианта настройки портов:
Desirable — когда порт посылает запросы о переходе в состояние агрегированного канала
Auto — когда порт в пассивном состоянии и ожидает получения сигналов с запросом о создании агрегированного канала с другого порта.
Если на обоих коммутаторах порты настроины в состоянии desirable то агрегированный канал будет сформирован.
Если но обоих коммутаторах порты настроины в состоянии auto то агрегированный канал не будет сформирован.

Важно: настройки портов ( Vlan, duplex, stp ) с обоих сторон должны быть одинаковыми.

Настройка коммутатора номер 1
Switch(config)# interface range fa0/23 – 24
Switch(config-if)# channel-protocol lacp
Switch(config-if)# channel-group 1 mode active

Настройка коммутатора номер 2
Switch(config)# interface range fa0/23 – 24
Switch(config-if)# channel-protocol lacp
Switch(config-if)# channel-group 1 mode passive

На портах обоих коммутаторов должен быть настрое протокол LACP.
Существует два варианта настройки портов:
Active — когда порт посылает запросы для формирования агрегированного канала.
Passive — когда порт находится в режиме ожидания и формирует агрегированный канал только в случае если он получает запросы с другого коммутатора.
Если на обоих сторонах коммутаторов порты будут настроены в режиме Active то агрегированный канал будет сформирован.
Если на обоих сторонах коммутаторов порты будут настроены в режиме Passive, то агрегированный канал не будет сформирован.

Важно: настройки портов ( Vlan, duplex, stp ) с обоих сторон должны быть одинаковыми.

Источник

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco

Агрегирование каналов (агрегация каналов, англ. link aggregation) — технология, которая позволяет объединить несколько физических каналов в один логический. Такое объединение позволяет увеличивать пропускную способность и надежность канала. Агрегирование каналов может быть настроено между двумя коммутаторами, коммутатором и маршрутизатором, между коммутатором и хостом.

Для агрегирования каналов существуют другие названия:

  • Port Trunking (в Cisco trunk’ом называется тегированный порт, поэтому с этим термином путаницы больше всего),
  • EtherChannel (в Cisco так называется агрегирование каналов, это может относиться как к настройке статических агрегированных каналов, так и с использованием протоколов LACP или PAgP)
  • И еще множество других: Ethernet trunk, NIC Teaming, Port Channel, Port Teaming, LAG (link aggregation), Link Bundling, Multi-Link Trunking (MLT), DMLT, SMLT, DSMLT, R-SMLT, NIC bonding, Network Fault Tolerance (NFT), Fast EtherChannel.
Читайте также:  Коллиматорный прицел инструкция по настройке

Общая информация об агрегировании каналов

Агрегирование каналов позволяет решить две задачи:

  • повысить пропускную способность канала
  • обеспечить резерв на случай выхода из строя одного из каналов

Большинство технологий по агрегированию позволяют объединять только параллельные каналы. То есть такие, которые начинаются на одном и том же устройстве и заканчиваются на другом.

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-0

Если рассматривать избыточные соединения между коммутаторами, то без использования специальных технологий для агрегирования каналов, передаваться данные будут только через один интерфейс, который не заблокирован STP. Такой вариант позволяет обеспечить резервирование каналов, но не дает возможности увеличить пропускную способность.

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-01

Без использования STP такое избыточное соединение создаст петлю в сети.

Технологии по агрегированию каналов позволяют использовать все интерфейсы одновременно. При этом устройства контролируют распространение широковещательных фреймов (а также multicast и unknown unicast), чтобы они не зацикливались. Для этого коммутатор, при получении широковещательного фрейма через обычный интерфейс, отправляет его в агрегированный канал только через один интерфейс. А при получении широковещательного фрейма из агрегированного канала, не отправляет его назад.

Хотя агрегирование каналов позволяет увеличить пропускную способность канала, не стоит рассчитывать на идеальную балансировку нагрузки между интерфейсами в агрегированном канале. Технологии по балансировке нагрузки в агрегированных каналах, как правило, ориентированы на балансировку по таким критериям: MAC-адресам, IP-адресам, портам отправителя или получателя (по одному критерию или их комбинации).

То есть, реальная загруженность конкретного интерфейса никак не учитывается. Поэтому один интерфейс может быть загружен больше, чем другие. Более того, при неправильном выборе метода балансировки (или если недоступны другие методы) или в некоторых топологиях, может сложиться ситуация, когда реально все данные будут передаваться, например, через один интерфейс.

Некоторые проприетарные разработки позволяют агрегировать каналы, которые соединяют разные устройства. Таким образом резервируется не только канал, но и само устройство. Такие технологии в общем, как правило, называются распределенным агрегированием каналов (у многих производителей есть своё название для этой технологии).

На этой странице рассматривается в основном агрегирование параллельных каналов. Для распределенного агрегирования выделен отдельный раздел в котором указаны соответствующие технологии некоторых производителей. Распределенное агрегирование в коммутаторах HP (ProCurve) рассмотрено более подробно.

Агрегирование каналов в Cisco

Для агрегирования каналов в Cisco может быть использован один из трёх вариантов:

  • LACP (Link Aggregation Control Protocol) стандартный протокол
  • PAgP (Port Aggregation Protocol) проприетарный протокол Cisco
  • Статическое агрегирование без использования протоколов

Так как LACP и PAgP решают одни и те же задачи (с небольшими отличиями по возможностям), то лучше использовать стандартный протокол. Фактически остается выбор между LACP и статическим агрегированием.

  • Преимущества:
    • Не вносит дополнительную задержку при поднятии агрегированного канала или изменении его настроек
    • Вариант, который рекомендует использовать Cisco
  • Недостатки:
    • Нет согласования настроек с удаленной стороной. Ошибки в настройке могут привести к образованию петель
Читайте также:  Иммергаз инструкция меню настроек

Агрегирование с помощью LACP:

  • Преимущества:
    • Согласование настроек с удаленной стороной позволяет избежать ошибок и петель в сети.
    • Поддержка standby-интерфейсов позволяет агрегировать до 16ти портов, 8 из которых будут активными, а остальные в режиме standby
  • Недостатки:
    • Вносит дополнительную задержку при поднятии агрегированного канала или изменении его настроек

Терминология и настройка

При настройке агрегирования каналов на оборудовании Cisco используется несколько терминов:

  • EtherChannel — технология агрегирования каналов. Термин, который использует Cisco для агрегирования каналов.
  • port-channel — логический интерфейс, который объединяет физические интерфейсы.
  • channel-group — команда, которая указывает какому логическому интерфейсу принадлежит физический интерфейс и какой режим используется для

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-03

Эти термины используются при настройке, в командах просмотра, независимо от того, какой вариант агрегирования используется (какой протокол, какого уровня EtherChannel).

На схеме, число после команды channel-group указывает какой номер будет у логического интерфейса Port-channel. Номера логических интерфейсов с двух сторон агрегированного канала не обязательно должны совпадать. Номера используются для того чтобы отличать разные группы портов в пределах одного коммутатора.

Общие правила настройки EtherChannel

LACP и PAgP группируют интерфейсы с одинаковыми:

  • скоростью (speed),
  • режимом дуплекса (duplex mode),
  • native VLAN,
  • диапазон разрешенных VLAN,
  • trunking status,
  • типом интерфейса.
  • Так как для объединения в EtherChannel на интерфейсах должны совпадать многие настройки, проще объединять их, когда они настроены по умолчанию. А затем настраивать логический интерфейс.
  • Перед объединением интерфейсов лучше отключить их. Это позволит избежать блокирования интерфейсов STP (или перевода их в состояние err-disable).
  • Для того чтобы удалить настройки EtherChannel достаточно удалить логический интерфейс. Команды channel-group удалятся автоматически.

Создание EtherChannel для портов уровня 2 и портов уровня 3 отличается:

  • Для интерфейсов 3го уровня вручную создается логический интерфейс командой interface port-channel
  • Для интерфейсов 2го уровня логический интерфейс создается динамически
  • Для обоих типов интерфейсов необходимо вручную назначать интерфейс в EtherChannel. Для этого используется команда channel-group в режиме настройки интерфейса. Эта команда связывает вместе физические и логические порты

После того как настроен EtherChannel:

  • изменения, которые применяются к port-channel интерфейсу, применяются ко всем физическим портам, которые присвоены этому port-channel интерфейсу
  • изменения, которые применяются к физическому порту влияют только на порт на котором были сделаны изменения

Настройка статической агрегации Etherchannel

Предположим есть две Cisco 2960 и компы, каждая Cisco на своем этаже, одного гигабитного порта не хватает, нужно сделать агрегирование. Схема представлена ниже.

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-04

Настроим наше оборудование на Etherchannel. Подключаемся к первой Cisco через ssh или терминал.

config t

Я буду использовать гигабитные интерфейсы gi1/1 и gi1/2. Выберем сразу диапазон интерфейсов.

int range gigabitEthernet 1/1-2

channel-group 1 mode on (только Etherchanne)
end
wr

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-05

На второй Cisco делаем тоже самое, один в один.

  • active — Включить LACP,
  • passive — Включить LACP только если придет сообщение LACP,
  • desirable — Включить PAgP,
  • auto — Включить PAgP только если придет сообщение PAgP,
  • on — Включить только Etherchannel.
Читайте также:  Настройка аутлук экспресс 2017

Комбинации режимов при которых поднимется EtherChannel:

Режим PAgP auto desirable
auto EtherChannel
desirable EtherChannel EtherChannel
Режим LACP passive active
passive EtherChannel
active EtherChannel EtherChannel

Интерфейсы в состоянии suspended

Если настройки физического интерфейса не совпадают с настройками агрегированного интерфейса, он переводится в состояние suspended. Это будет видно в нескольких командах.

Просмотр состояния интерфейсов:

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-06

Просмотр информации о EtherChannel

sh etherchannel summary

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-07

sh etherchannel port-channel

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-08

Настройка LACP

Теперь представим что у нас есть ядро и два коммутатора доступа L2. И между L2 и ядром нужно настроить агрегацию с помощью протокола LACP.

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-09

Перед настройкой агрегирования лучше выключить физические интерфейсы. Достаточно отключить их с одной стороны (в примере на sw1), затем настроить агрегирование с двух сторон и включить интерфейсы.

Подключаемся ко второй Cisco через ssh или терминал.

config t

Я буду использовать гигабитные интерфейсы fa0/23-24

interface range fa0/23-24
channel-protocol lacp (подготовка для lacp)
channel-group 1 mode passive (режим пассивный так как активный будет на ядре)

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-10

Посмотрим настройки show etherchannel summary

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-11

Делаем на втором коммутаторе L2 тоже самое.

Теперь настроим ядро на уровне L3.

Подключаемся к ядру Cisco через ssh или терминал.

config t

Будем настраивать две пары портов fa0/1-2 и fa0/3-4

interface range fastEthernet 0/1-2
channel-protocol lacp

channel-group 1 mode active

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-12

Аналогично настроим fa0/3-4

interface range fastEthernet 0/3-4
channel-protocol lacp

channel-group 2 mode passive

exit

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-1

Смотрим что настроили

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-14

Подключаем линки и видим что все ок

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-15

Что такое и как настроить Link Aggregation Control Protocol (LACP) на примере Cisco-16

LACP с VLAN

Если у вас есть vlan, то каждую port-channel Нужно перевести в режим trunk командой

switchport mode trunk

НА коммутаторе третьего уровня сначала нужно создать нужные vlan и задать им ip адреса, а уже потом переводить port-channel в режим trunk. Для примера создам vlan 2 и назначу ему ip.

ip address 192.168.2.251 255.255.255.0

int port-channel 1

switchport trunk encapsulation dot1q

switchport mode trunk

Для второй port-channel тоже самое, в итоге у вас будет работать вот такая схема.

Мы разобрали как настроить Link Aggregation Control Protocol (LACP) на примере Cisco.

Источник

Adblock
detector