Меню

Настройка dial peer voip



CISCO: настройка dial-peer

Для понимания, как вообще в двух словах настроить dial-peer в cisco

Диалпир может быть входящим, так и исходящим, необязательно к нему может быть прикручен translation-profile с translation-rule для изменения звонка

Рассмотрим на примере:

К нам приходит звонок(от провайдера\атс и т.п.) например 88001112233 (совпадает с диалпир 134)

Далее его нам надо переделать в 1111 (уходит в 135 уже исходящем диалпире в translation-profile outgoing 3) и отправить далее например на астериск или телефон (session target ipv4:192.168.1.10)

!
voice translation-profile 3
translate called 3
!
voice translation-rule 3
rule 1 /^88001112233$/ /1111/
rule 2 /.*/ //
!

dial-peer voice 134 voip
description ==From provider incoming 8-800 number==
incoming called-number ^88001112233$
dtmf-relay rtp-nte
codec g711alaw
fax-relay ecm disable
fax rate 9600
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 135 voip
description ==To telephone number 1111==
translation-profile outgoing 3
destination-pattern ^88001112233$
session protocol sipv2
session target ipv4:192.168.1.10
dtmf-relay rtp-nte
codec g711alaw
fax-relay ecm disable
fax rate 9600
fax protocol pass-through g711ulaw
no vad
!

Источник

Создание dial-peer на шлюзе AddPac

В общем виде соединение можно представить в виде двух частей:
одна — от телефона до шлюза (pots)
другая — от шлюза до следующего шлюза (voip)
каждая часть описывается с помощью блока dial-peer.
Вот мы сейчас и сконфигурируем эти диал-пиры.

    сначала для портов FXS (pots dial-peers) (создаем на каждый канал FXS свой диал-пир, и присваиваем таким образом каналу номер):

AP200(config)# dial-peer voice 1 pots
AP200(config-dialpeer-pots-1)# port 0/0
AP200(config-dialpeer-pots-1)# destination-pattern 200
AP200(config-dialpeer-pots-1)# exit

AP200(config)# dial-peer voice 2 pots
AP200(config-dialpeer-pots-2)# port 0/1
AP200(config-dialpeer-pots-2)# destination-pattern 200
AP200(config-dialpeer-pots-2)# exit

теперь для VoIP:

AP200(config)# dial-peer voice 100 voip
(номер (100) любой — для каждого диал-пира свой)
AP200(config-dialpeer-voip-100)# destination-pattern 9T

(т.е. по девятке будем передавать звонок на шлюз, который сейчас укажем (без помощи гейткипера))

AP200(config-dialpeer-voip-100)# session target 200.200.200.200

(указываем адрес шлюза, на который будет переключаться звонок, через пробел можно после адреса указать порт, если он отличается от стандартного)

AP200(config-dialpeer-voip-100)# preference 1

(если несколько dial-peer’ов на один шаблон номера, то они будут выбираться в соответствии с приоритетом)

AP200(config-dialpeer-voip-100)# voice-class codec 1
(говорим, чтоб это соединение использовало кодеки из ранее созданного класса кодеков)

AP200(config-dialpeer-voip-100)# exit
AP200(config)# write

Посмотреть, что мы наваяли можно скомандовав:

AP200# show dial-peer voip summary
AP200# show dial-peer pots summary

Теперь можно звонить самому на себя набрав номер порта FXS, который присваивали при создании pots dial-peer и на шлюз, прописанный в voip dial-peer.

Источник

antiCisco blogs

блоги по технологиям и оборудованию cisco от инструкторов

Про голос. Собираем лабу 2. FXS & Dial-peers.

Опубликовано solo 4 Февраль , 2011

Задача тактическая: Подключить к голосовым портам 2611 два аналоговых телефона. Добиться взаимодействия телефонов между собой и IP-телефонами, зарегистрированными на 2800. Номера портов/адресация — см. рисунок.

Проводим базовую настройку

Будет маршрутизатором офиса “BR” компании “1”
Router(config)#hostname BR1

Связь между HQ1 и BR1 у меня через 18-й VLAN.
Создаем соответствующий сабинтерфейс и устанавливаем на него IP-адрес.
BR1(config)#int e0/0.18
BR1(config-subif)#encapsulation dot1Q 18
BR1(config-subif)#ip address 172.18.1.2 255.255.255.0

Создаем лупбек для будущих диапиров.
BR1(config)#int loo 0
BR1(config-if)#ip add 192.168.0.2 255.255.255.255

Аналоговые порты бывают:

FXS(Foreign Exchange Station) — порт станции. Для лёгкости запоминания — это тот порт, к которому мы подключаем телефоны и “он в них гудит”. FXS-порты — это телефонные розетки.

FXO(Foreign Exchange Office) — абонентский порт. Это порт самого телефона — тот который получает напряжение.

Таким образом к FXS-порту подключается FXO-порт. Один выдаёт напряжение, другой получает. С одной стороны станция, с другой — абонент. Взаимодействие FXS-FXS и FXO-FXO невозможно. FXS-FXO — это связка ведущий-ведомый. Оба типа портов используют для работы 2 провода.

Все 3 типа голосовых портов встречается на маршрутизаторах Cisco; т.е. в зависимости от оснащённости портами устройство может выступать как в роли станции (FXS, E&M), так и в роли телефона (FXO).

Читайте также:  D90 nikon советы по настройке

Поднимаем трубки. Слышим гудок. Работают.

Кстати, тут же можем с налету поменять тип Call Progress тонов:
BR1(config)#voice-port 1/0/0
BR1(config-voiceport)#cptone RU
BR1(config)#voice-port 1/0/1
BR1(config-voiceport)#cptone RU

Можно выбрать и рингтон:
BR1(config-voiceport)#ring cadence ?
define User Defined Cadence
pattern01 2sec on 4sec off
pattern02 1sec on 4sec off
pattern03 1.5sec on 3.5sec off
pattern04 1sec on 2sec off
pattern05 1sec on 5sec off
pattern06 1sec on 3sec off
pattern07 .8sec on 3.2sec off
pattern08 1.5sec on 3sec off
pattern09 1.2sec on 3.7sec off
pattern10 1.2sec on 4.7sec off
pattern11 .4sec on .2sec off .4sec on 2sec off
pattern12 .4sec on .2sec off .4sec on 2.6sec off

Я оставлю по дефолту, но эстеты могут наваять свой при помощи команды “ring cadence
define”.

Тут же есть полезные таймеры:

Теперь пора бы и позвонить. Но сначала, да, она — теория.

Для направления вызовов на оборудовании Cisco используются “дайлриры” (Dial-peer), которые в просторечии называют диалпирами.

В первом приближении диалпиры делятся на VoIP (регламентирующие обработку вызовов в IP-сетях) и POTS (для работы с сетями традиционной телефонией).

Тип диалпира указывается при его создании:
(config)#dial-peer voice <номер диалпира>

  • Для каждого вызова ВСЕГДА есть входящий диалпир.
  • Для вызова МОЖЕТ быть найден исходящий диалпир.
  • Один и тот же диалпир может быть одновременно и входящим и исходящим, но не для одного и того же звонка.

В Destination-pattern номерной план можно указывать как в явном виде (диалпир #3 в примере ниже), так и в виде регулярных выражений.

Примеры :
dial-peer voice 1 voip
destination-pattern 3T =Номер любой длины, начинающийся с 3=
session-target ipv4:10.1.1.1

dial-peer voice 2 voip
destination-pattern 333… =6-ти значные номера, начинающийся с 333=
session-target ipv4:10.2.2.2

dial-peer voice 3 voip
destination-pattern 333444 =Номер 333444=
session-target ipv4:10.3.3.3

dial-peer voice 4 voip
destination-pattern 333[4-8]44 -=6-ти значные номера, начинающиеся “333”, далее цифра от 4 до 8, и ещё “44”=-
session-target ipv4:10.4.4.4

Набрали номер 333444
В принципе вызов попадает под все диалпиры. Будет выбран тот, который подразумевает самое “точное” совпадение — в нашем случае #3.

набрали номер 333448
Вызов попадает под диалпиры 1 и 2. Диалпир #2 обеспечивает наименьшее количество “разночтений” — по нему и уйдёт вызов.

Критерии выбора входящего диалпира в порядке применения:

1. Наиболее точное совпадение параметра диалпира “incoming called-number” с DNIS (Dialed Number Identification Service) — это КОМУ звонят.
2. Наиболее точное совпадение параметра диалпира “answer-address” с ANI (Automatic number identification) — это КТО звонит.
3. Наиболее точное совпадение параметра диалпира “destination-pattern” с ANI.
4. Для POTS диалпиров вызов принимает на тот диалпир, который указывает на порт, с которого звонок собственно пришел.

Особо толковые парни конечно спросят: “А чО делать если все совпадают?”.
А вот тут из кустов появляется невидимый и универсальный диалпир #0, на который могут приняться как VoIP, так и POTS вызовы.
Вывод: Входящий диалпир найдут всегда, даже если вы этого не очень хотите.

Вернемся к исходящим…
С destination-pattern в целом разобрались, теперь собственно мы должны указать куда слать вызов при совпадении DNIS с destination-pattern. Тут все просто.

Для VoIP указываем IP-адрес следующего устройства
dial-peer voice 1 voip
description VOIP-DIALPEER
destination-pattern 9T
session target ipv4:192.168.168.168

BR1(config-dial-peer)#dial-peer voice 1202 pots
BR1(config-dial-peer)#destination-pattern 1202
BR1(config-dial-peer)#port 1/0/1
BR1(config-dial-peer)#description WHITE-PHONE

Кто не пишет “дескрипшены” к диалпирам, того многократно поразит постыдная неудача с женщиной.

Проверяем волшебной командой:
BR1#csim start 1201 — звенит!
BR1#csim start 1202 — звенит!

Звоним с одного телефона на другой — все равно работает.

Далее хочу обеспечить звонки с BR1 на HQ1 и обратно. Связь между ними по IP, а значит требуются “коннективити”. Одним из способов приподнять себе карму являются диалпиры указывающие на лупбеки.

Читайте также:  Настройки профиля в инстаграме

Включаем на устройствах OSPF:

BR1(config)#router ospf 1
BR1(config-router)#net 172.18.1.2 0.0.0.0 area 0
BR1(config-router)#net 192.168.0.2 0.0.0.0 area 0

HQ1(config)#int loo 0
HQ1(config-if)#ip ospf 1 area 0
HQ1(config-if)#int f0/0.16
HQ1(config-subif)#ip ospf 1 area 0
HQ1(config-subif)#int f0/0.17
HQ1(config-subif)#ip ospf 1 area 0
HQ1(config-subif)#int f0/0.18
HQ1(config-subif)#ip ospf 1 area 0

Проверяем, что на HQ1 прилетел лупбек BR1:
HQ1#sh ip route ospf
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
O 192.168.0.2/32 [110/2] via 172.18.1.2, 00:00:21, FastEthernet0/0.18

Рисуем на HQ1 воипный диалпир, указывающий на телефоны BR1:
HQ1(config)#dial-peer voice 1200 voip
HQ1(config-dial-peer)#destination-pattern 120.
HQ1(config-dial-peer)#session target ipv4:192.168.0.2
HQ1(config-dial-peer)#description TO-BR1’s-ANALOG-PHONES

Звоню с IP-телефонов — работает!
Звонок с аналоговых на IP естественно не проходит, т.к. на этом этапе BR1 не знает где они находятся.

Исправляем недоработку:
BR1(config)#dial-peer voice 1100 voip
BR1(config-dial-peer)#destination-pattern 110.
BR1(config-dial-peer)#session target ipv4:192.168.0.1
BR1(config-dial-peer)#description TO-HQ1’s-IPPHONES

Звоню с аналоговых на IP — работает! Миракл!

Смотрите в следующих сериях: “Зачем еще нужны диалпиры”, “Манипуляции с цифрами”, “Продвинутая настройка CUCME”.

Источник

Подключение и настройка VoIP шлюза (SIP шлюза)

В этом материале мы рассмотрим особенности подключения и настройки VoIP шлюза (SIP шлюза). Разбирать все нюансы будем на примере аналоговых VoIP шлюзов с портами FXS/FXO.

Очень распространенная ситуация, когда в компании с аналоговой внутренней телефонной сетью есть филиал или несколько филиалов. Связь с филиалами осуществляется через телефонную сеть общего пользования (ТфОП), что при условии сильной удаленности филиалов может стоить очень дорого. Поэтому всё больше компаний организовывают VPN-каналы через сеть Интернет для того, что бы удаленные офисы могли пользоваться сетевыми ресурсами главного офиса (медиа ресурсы, файловые серверы, базы данных). Эти же Интернет-каналы могут использовать VoIP шлюзы (они же SIP шлюзы) для передачи голосового телефонного трафика.

Подключение и настройка VoIP/SIP шлюзов для связи с филиалами

Рассмотрим подключение удаленных филиалов компании с помощью VoIP/SIP шлюзов производства компании AddPac. Схема подключения выглядит следующим образом:

Как мы видим из этой схемы, полностью исключается ТфОП, как звено для связи между филиалами. К тому же появляется возможность выходить на городскую телефонную сеть (ГТС) удаленного офиса, минуя каналы ТфОП. Например, звонить из Екатеринбурга по Москве теперь можно бесплатно через московский офис.

Далее рассмотрим простой пример подключения аналоговых телефонов через VoIP/SIP шлюз AddPac AP1100.

Для этого нам понадобятся: шлюз AddPac AP1100C (8 портов FXO, для подключения к УАТС) и шлюз AddPac AP1100B (8 портов FXS, для подключения аналоговых телефонов).

Настройку VoIP/SIP шлюзов целесообразно производить из консоли. Для подключения через консольный кабель удобно воспользоваться бесплатным программным обеспечением Putty (скачать программу Putty можно тут по адресу: chiark.greenend.org.uk)

Настройка VoIP шлюза (SIP шлюза) со стороны УАТС

Начинаем с настройки VoIP/SIP шлюза AddPac AP1100C со стороны УАТС. Для начала зададим IP-адрес шлюзу и пропишем маршрут (Route) по умолчанию:

Router# configure terminal

Router(config)# interface FastEthernet 0/0

Router(config-if)# ip address 192.168.0.179 255.255.255.0

Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.1

Теперь сконфигурируем FXO порты. Включаем определитель номера:

Router(config)# voice-port 0/0

Router(config-voice-port-0/0)# caller-id enable

Router(config)# voice-port 0/1

Router(config-voice-port-0/1)# caller-id enable

Прописываем на портах горячую линию (connection plar), что бы вызов сразу отправлялся по указанному номеру и таймаут определения звонка

Router(config)# voice-port 0/0

Router(config-voice-port-0/0)#connection plar 101

Router(config-voice-port-0/0)# ring detect-timeout 50

Router(config)# voice-port 0/1

Router(config-voice-port-0/1)# connection plar 102

Router(config-voice-port-0/0)# ring detect-timeout 50

Создаем маршруты для входящих звонков для аналоговых портов FXO

Router(config)# dial-peer voice 101 pots

Router(config-dialpeer-pots-101)# destination-pattern 1101

Router(config)# dial-peer voice 102 pots

Router(config-dialpeer-pots-102)# destination-pattern 1102

Мы не случайно добавили цифру «1» к номерам. С удаленной стороны тоже будет «connection plar», и чтобы вызов не заворачивался сам на себя, мы слегка изменяем номер. На физическое соединение с портом на АТС это никак не повлияет.

Читайте также:  Реестр настройки mail ru

Теперь создадим маршрут на удаленный шлюз через VoIP

Router(config)# dial-peer voice 1000 VoIP

Router(config-dialpeer-VoIP-1000)# destination-pattern 10.F

Router(config-dialpeer-VoIP-1000)# session target 192.168.0.180

Router(config-dialpeer-VoIP-1000)# session protocol sip

Router(config-dialpeer-VoIP-1000)# dtmf-relay rtp-2833

Здесь мы указали, чтобы все номера, похожие на 10Х отправлялись на IP адрес 192.168.0.180 по протоколу SIP, DTMF метод RFC2833 (важный параметр).

На этом настройка первого шлюза закончена. Сохраним конфигурацию в памяти.

Proceed with write? [confirm]

[OK] Configuration saved to flash:apos.cfg

Настройка VoIP шлюза (SIP шлюзы) для подключения аналоговых телефонов

Переходим к настройке второго (удаленного) шлюза. Таким же методом, как описано выше, делаем сетевые настройки. Также настраиваем порты:

Router(config)# voice-port 1/0

Router(config-voice-port-1/0)# caller-id enable

Router(config-voice-port-1/0)#connection plar 1101

Router(config)# voice-port 1/1

Router(config-voice-port-1/1)# caller-id enable

Router(config-voice-port-1/1)#connection plar 1102

Создаем маршруты для входящих звонко для аналоговых портов FXS

Router(config)# dial-peer voice 101 pots

Router(config-dialpeer-pots-101)# destination-pattern 101

Router(config)# dial-peer voice 102 pots

Router(config-dialpeer-pots-102)# destination-pattern 102

И маршрут в сторону VoIP

Router(config)# dial-peer voice 1000 VoIP

Router(config-dialpeer-VoIP-1000)# destination-pattern 110.F

Router(config-dialpeer-VoIP-1000)# session target 192.168.0.179

Router(config-dialpeer-VoIP-1000)# session protocol sip

Router(config-dialpeer-VoIP-1000)# dtmf-relay rtp-2833

Proceed with write? [confirm]

[OK] Configuration saved to flash:apos.cfg

На этом настройка закончена. Теперь можно проверить прохождение звонков и разнести шлюзы по удаленным сторонам. Сетевую маршрутизацию необходимо настроить так, что бы шлюзы видели друг друга по IP адресу.

Подключение и настройка VoIP шлюза (SIP шлюза) для работы с оператором IP телефонии

В настоящее время всё популярнее становятся операторы IP телефонии, предоставляющие услуги связи по протоколу SIP через сеть интернет. Уже практически все крупные операторы в дополнение к услугам IP телефонии предлагают прямой локальный входящий городской номер и организацию виртуальной АТС на своем оборудовании. В связи с этим для малых компаний, которые к тому же постоянно меняют адрес, отпадает надобность в прокладке телефонных линий по медной паре, а в случае с виртуальной АТС, в организации собственной телефонной сети. Но многие всё же оставляют свои старые аналоговые АТС и телефонные аппараты (хотя IP телефоны уже достаточно дёшевы), поскольку они стабильны и неприхотливо работают уже много лет.

Для подключения к VoIP-системам связи или оператору SIP также обычно используются VoIP/SIP шлюзы.

Рассмотрим пример подключения 2-х аналоговых телефонов через VoIP-шлюз AddPac AP1100F к популярному SIP-оператору связи SIPNET.

Для начала сетевые настройки VoIP/SIP шлюза. На этот раз дадим шлюзу получить IP адрес автоматически по DHCP:

Router# configure terminal

Router(config)# interface FastEthernet 0/0

Router(config-if)# ip address dhcp

После того, как интерфейс LAN0 поднялся и получил IP, приступим к настройке маршрутов и аккаунта. Создадим диал-пиры для аналоговых портов

Router(config)# dial-peer voice 0 pots

Router(config-dialpeer-pots-0)#destination-pattern 0041790267 (ваш ID в SIPNET)

Router(config)# dial-peer voice 1 pots

Router(config-dialpeer-pots-1)#destination-pattern 0041790267 (ваш ID в SIPNET)

Теперь диал-пир в сторону SIPNET

Router(config)# dial-peer voice 1000 VoIP

Router(config-dialpeer-VoIP-1000)# destination-pattern T

Router(config-dialpeer-VoIP-1000)# session target sip-server

Router(config-dialpeer-VoIP-1000)# session protocol sip

Router(config-dialpeer-VoIP-1000)# voice-class codec 0

Добавим возможность удержания вызова (hold) и перевода звонка (transfer)

Router(config)# dial-peer call-hold h

Router(config)# dial-peer call-transfer h

Создадим класс кодеков с приоритетами

Router(config)# voice class codec 0

Router(config-vclass-codec#0)# codec preference 1 g711alaw

Router(config-vclass-codec#0)# codec preference 2 g729

Настройка sip user-agent

Router(config-sip-ua)# sip-username 0041790267 (ваш ID в SIPNET)

Router(config-sip-ua)# sip-password ******** (ваш пароль в SIPNET)

Router(config-sip-ua)# sip-server sipnet.ru

Router(config-sip-ua)# srv enable

Router(config-sip-ua)# register e164

Proceed with write? [confirm]

[OK] Configuration saved to flash:apos.cfg

Подключение и настройка VoIP/SIP шлюза закончена. Теперь можно звонить с аналоговых телефонов через SIPNET. Входящие звонки из SIPNET будут приходить на порт FXS 1/0, а при его занятости на порт FXS 1/1. Также вместо телефонных аппаратов к портам FXS можно подключить линии от аналоговой мини-АТС.

Источник

Adblock
detector