Меню

Mikrotik настройка резервирования lte



Резервирование Интернет-канала на Mikrotik

В данной инструкции мы рассмотрим пример настройки двух Интернет-каналов одновременно на роутере Mikrotik с целью отказоустойчивости — при разрыве соединения основной канал будет меняться на резервный. В нашем случае будет задействован один WAN Ethernet, второй — LTE. Итого, два провайдера и две сети.

Есть два способа настройки отказоустойчивости:

  1. Настройка балансировки между шлюзами (разные приоритеты для интерфейсов). Данный метод можно использовать, если у нас оба провайдера предоставляют настройки со статическим адресом шлюза. Настройка выполняется без скриптов через конфигурирование нескольких шлюзов с разным весом.
  2. Проверка доступности основного Интернет-канала и переключение на резервный при наличии проблем. Это универсальный метод настройки отказоустойчивости. Для настройки используется утилита Netwatch, которая выполняет скрипт проверки и, при необходимости, смены основного шлюза для доступа к сети Интернет.

Мы рассмотрим оба варианта. Настройки выполним в программе winbox. Настройка в веб-интерфейсе аналогична.

Перед началом, убедитесь, что по отдельности микротик раздает Интернет от обоих провайдеров.

Маршруты с разным приоритетом

Раскрываем в меню IP:

. и переходим в Routes:

Добавляем 2 маршрута. Первый через одного Интернет провайдера со следующими настройками:

* мы указываем шлюз от нашего провайдера (в данном примере 1.1.1.1), задаем настройку проверки шлюза (Check Gateway) с помощью утилиты ping, задаем приоритет (Distance 10).

Для второго провайдера мы задаем, практически, аналогичные настройки:

* обратите внимание, что в отличие от первого маршрута, в данном указана большая дистанция и другой шлюз (для второго провайдера).

После удаляем старые маршруты. Должны остаться только те, что мы добавили.

Использование сценария, запускаемого в Netwatch

Данный метод поможет настроить резервирование канала, если один из провайдеров выдает динамические адреса в разных подсетях, например, подключение через 4G-модем.

1. Задаем описания

Сначала необходимо задать описание для маршрутов. Это понадобиться для сценария, который будет работать с последними через данные описания.

Раскрываем в меню IP:

. и переходим в Routes:

Открываем на редактирование оба маршрута через наших провайдеров и добавляем комментарий в разделе Comment:

2. Настраиваем узел для проверки канала

Мы настроим узел, который будет пинговать провайдер 1. Если пинг пропадает, то необходимо переключать активный Интернет-канал на провайдера 2. Также мы должны заблокировать возможность пинговать проверочный узел с провайдера 2.

И так, переходим к настройке маршрутов:

Добавляем новый маршрут к проверочному узлу, например 77.88.8.2 (DNS Яндекса):

* в данной настройке мы задали маршрут к проверочному узлу через шлюз 1.1.1.1 (в нашем примере это шлюз от провайдера 1).

Переходим в IPFirewall:

Создаем новое правило для запрета пинга проверочного узла через провайдера номер 2:

. в качестве действия выбираем drop:

3. Настройка задания в Netwatch

Переходим в ToolsNetwatch:

Создаем новое правило. На вкладке Host прописываем следующее:

* в данном примере мы будем проверять узел 77.88.8.2 раз в минуту.

На вкладке Up пропишем:

/ip route set [find comment=»ISP_1″] disabled=no
/ip route set [find comment=»ISP_2″] disabled=yes

. а на вкладке Down следующее:

/ip route set [find comment=»ISP_1″] disabled=yes
/ip route set [find comment=»ISP_2″] disabled=no

Нажимае OK.

Проверка

Для проверки отказоустойчивости лучше всего отключить кабель основного провайдера (вытащить провод из WAN-разъема) — через небольшой промежуток времени Mikrotik должен начать раздавать Интернет второго провайдера. Проверить, что внешний канал изменился можно с помощью различных сайтов, например, 2ip.ru.

Читайте также

Данная информация также может быть полезной:

Источник

Настройка резервирования интернет-канала (Mikrotik)

Отсутствие интернета в компании даже на 10 минут может повлечь серьезные убытки для бизнеса. Именно поэтому подавляющее большинство наших клиентов используют технологию резервирования интернет-канала.

В данной инструкции мы опишем пример базовой настройки резервирования интернет-канала на базе оборудования Mikrotik RB951G. Вариантов реализации данного решения в сети довольно много. Мы же опишем свою версию реализации используя утилиту Netwatch.

Читайте также:  Turnigy 9x настройка закрылок

Состав тестового стенда:

  • Mikrotik RB951G. Версия OS 6.45.1
  • LTE-модем Yota

Этап 1. Подготовительные работы:

Предлагаем не углубляться в этап начальной настройки устройства. Подразумеваем, что базовая настройка устройства уже проведена, адреса получены, LTE-модем убран из вкладки Bridge.

Во вкладке Address List имеем:

  • Lte1 – получен адрес по DHCP (D – Dinamic) 10.0.0.10
  • WAN1 — получен адрес по DHCP (D – Dinamic) 172.17.0.51
  • Bridge1 ( наша локальная сеть) — 192.168.1.1 – адрес маршрутизатора.

В данном окне создаём 2 правила. Как создать правила и базовую настройку смотрим в статье.

Мы сделали отдельной правило, разрешающее интернет для каждого интерфейса, но можно использовать Interface list и создать только одно правило (см. рисунок ниже).

Этап 2. Настройка маршрутов

Кратко опишем процесс работы по проверке работы канала и алгоритма переключения на резервный канал и обратно.

Выбираем IP-адрес в интернете с высокой степенью доступности. В качестве примера используем IP 8.8.8.8.

Создаем дополнительный маршрут основного канала (цифра 3 на рисунке ниже) и правило в таблице маршрутизации, которое жестко привязывает прохождение трафика через канал WAN1 в случае переключения на резервный канал, пакеты будут пытаться отправляться через новый маршрут по умолчанию.

Обозначения на рисунке:

  1. Маршрут по умолчанию для основного провайдера с комментарием EFSOL.
  2. Маршрут по умолчанию для резервного провайдера с комментарием YOTA.
  3. Новый маршрут вне основной таблицы маршрутизации. Для него мы и делаем отдельное правило (см. рисунок ниже).

Новому правилу необходимо присвоить Routing mark. В нашем случаем мы назвали его — enternal.

В качестве примера откроем маршрут по умолчанию для основного провайдера.

В поле Gateway необходимо указывать IP-адрес шлюза. WInbox по умолчанию предлагает выбрать интерфейс. В данной версии прошивки данная функция работает некорректно. Если указать название интерфейса, маршрут не активируется.

Поле Pref.Source можно оставить пустым, но для большей надежности мы решили закрепить прохождение трафика через этот шлюз.

Создаем правило, которое говорит нам о том, что весь трафик, идущий на адрес 8.8.8.8 направлять только через таблицу enternal.

Сначала создается маршрут и в нем прописывается routing mark, и только потом мы найдем вновь созданный routing mark в поле Table.

Настройка таблицы маршрутизации завершена.

Этап 3. Настройка скрипта переключения

В качестве основного инструмента переключения мы будем использовать Netwatch. В качестве примера – интервал проверки мы сделали 15 секунд. В реальных условиях рекомендуем увеличить значение до 10 минут. Если основной канал будет активен, но работать нестабильно (потери пакетов), то роутер будет переключать интерфейсы. Соответственно, ни основной ни резервный канал корректно работать не будут.

Сам скрипт выглядит следующим образом. Поиск ведется по комментариям, присвоенным маршрутам.

Поле UP:

Поле DOWN:

На этом настройка резервирования канала завершена.

Источник

Mikrotik Настройка резервного канала в Routeros

Задача: Настройка резервного канала Mikrotik

Предположим, у нас есть Mikrotik и два интернет-провайдера, предоставляющих доступ в сеть через проводное соединение. От первого провайдера мы должны получить настройки по dhcp, для второго их нужно задать статически. Нам требуется обеспечить безотказную работу интернет-соединения. Для этого при возникновении проблем с доступом в интернет через основной канал (первого провайдера) наш маршрутизатор должен автоматически переключаться на резервный (второго провайдера), и, при восстановлении связи, продолжать работу в штатном режиме. Сразу условимся: в первый порт будет подключен основной провайдер, во второй — резервный, остальные три порта будут использоваться для подключения компьютеров локальной сети. О работоспособности канала будем судить по доступности ip-адреса. Для проверки лучше всего взять адрес какого-либо крупного сервиса, вероятность отказа которого крайне мала (мы выбрали google dns).

Читайте также:  Настройка приоритета трафика zyxel

1. Очистка конфигурации Mikrotik роутера

Для того, чтобы процесс настройки был понятней, и в дальнейшем не возникло путаницы, мы удалим стандартную конфигурацию и будем все делать с нуля. После очистки конфигурации к роутеру mikrotik можно подключиться только по mac-адресу через программу winbox.

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/1-mikrotik-настройка-резервного-канала-в-routeros-300×274.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/1-mikrotik-настройка-резервного-канала-в-routeros.png» title=»Очистка конфигурации Mikrotik роутера» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20365%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/1-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»Очистка конфигурации Mikrotik роутера» width=»400″ height=»365″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/1-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/1-mikrotik-настройка-резервного-канала-в-routeros-300×274.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> Очистка конфигурации Mikrotik роутера

2. Настройка интерфейсов и создание сетевого моста («bridge») на Mikrotik

В системе управления каждый интерфейс имеет свое имя. Имеет смысл присвоить интерфейсам устройства хорошо различимые понятные имена, что в будущем позволит существенно облегчить настройку и мониторинг системы.

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/2-mikrotik-настройка-резервного-канала-в-routeros-300×221.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/2-mikrotik-настройка-резервного-канала-в-routeros.png» title=»2. Настройка интерфейсов и создание сетевого моста («bridge») на Mikrotik» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20295%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/2-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»2. Настройка интерфейсов и создание сетевого моста («bridge») на Mikrotik» width=»400″ height=»295″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/2-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/2-mikrotik-настройка-резервного-канала-в-routeros-300×221.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> 2. Настройка интерфейсов и создание сетевого моста («bridge») на Mikrotik

Следующей задачей для нас является настройка внутренней сети. Для обеспечения взаимосвязи между компьютерами и устройствами локальной сети проще всего воспользоваться функциями сетевого моста («Bridge»), который позволяет объединить внутренние сетевые интерфейсы и обеспечить прозрачный доступ внутри сети.

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/3-mikrotik-настройка-резервного-канала-в-routeros-300×221.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/3-mikrotik-настройка-резервного-канала-в-routeros.png» title=»Настройка интерфейсов и создание сетевого моста («bridge») на Mikrotik» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20294%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/3-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»Настройка интерфейсов и создание сетевого моста («bridge») на Mikrotik» width=»400″ height=»294″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/3-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/3-mikrotik-настройка-резервного-канала-в-routeros-300×221.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> Настройка интерфейсов и создание сетевого моста («bridge») на Mikrotik

Для создания сетевого моста необходимо воспользоваться пунктом меню «Bridge», указать требуемое имя моста и в закладке «Ports» добавить в мост требуемые внутренние интерфейсы.

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/4-mikrotik-настройка-резервного-канала-в-routeros-300×222.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/4-mikrotik-настройка-резервного-канала-в-routeros.png» title=»Mikrotik Настройка резервного канала в Routeros» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20296%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/4-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»Mikrotik Настройка резервного канала в Routeros» width=»400″ height=»296″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/4-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/4-mikrotik-настройка-резервного-канала-в-routeros-300×222.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> Mikrotik Настройка резервного канала в Routeros

3. Добавление ip-адресов

Далее нужно добавить внутренний ip адрес, который будет являться шлюзом для нашей локальной сети (обратите внимание, что его нужно присвоить интерфейсу сетевого моста), а так же ip-адрес, который нам предоставляет второй провайдер.

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/5-mikrotik-настройка-резервного-канала-в-routeros-300×247.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/5-mikrotik-настройка-резервного-канала-в-routeros.png» title=»3. Добавление ip-адресов» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20329%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/5-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»3. Добавление ip-адресов» width=»400″ height=»329″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/5-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/5-mikrotik-настройка-резервного-канала-в-routeros-300×247.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> 3. Добавление ip-адресов

4. Настройка внутреннего dhcp-сервера

Теперь мы должны настроить параметры внутреннего DHCP сервера для раздачи IP адресов устройствам внутренней сети. Сначала необходимо создать пул выдаваемых IP адресов, для чего открываем пункт меню «IP»-«Pool», создаем новый пул, присваиваем ему различаемое имя и указываем диапазон выдаваемых адресов.

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/6-mikrotik-настройка-резервного-канала-в-routeros-300×250.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/6-mikrotik-настройка-резервного-канала-в-routeros.png» title=»3. Добавление ip-адресов» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20333%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/6-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»3. Добавление ip-адресов» width=»400″ height=»333″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/6-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/6-mikrotik-настройка-резервного-канала-в-routeros-300×250.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> 3. Добавление ip-адресов

Теперь можно приступать к настройке собственно DHCP сервера. Для этого необходимо перейти в пункт меню «IP»-«DHCP Server» и создать новый сервер, указав его имя, интерфейс на котором сервер будет работать (в нашем случае это сетевой мост) и ранее настроенный пул выдаваемых адресов. После этого мы должны указать параметры сети для нашего DHCP севера. Для этого нужно перейти на закладку «Network» и указать параметры передаваемые клиентам.

Mikrotik Настройка резервного канала в Routeros

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/7-mikrotik-настройка-резервного-канала-в-routeros-300×248.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/7-mikrotik-настройка-резервного-канала-в-routeros.png» width=»400″ height=»331″ svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20331%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/7-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»»

5. Создание dhcp-клиента

Так как подключение к сети первого провайдера предполагается осуществлять с использованием динамического адреса, значит нам нужно создать dhcp-клиента, работающего на первом порту маршрутизатора. Сделать это можно из меню «IP» — «Dhcp client».

Читайте также:  Настройка оперы чтобы открывалась экспресс панель

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/8-mikrotik-настройка-резервного-канала-в-routeros-300×251.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/8-mikrotik-настройка-резервного-канала-в-routeros.png» title=»Настройка резервного канала Mikrotik» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20334%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/8-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»Настройка резервного канала Mikrotik» width=»400″ height=»334″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/8-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/8-mikrotik-настройка-резервного-канала-в-routeros-300×251.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> Настройка резервного канала Mikrotik

6. Добавление статических маршрутов

Все взаимодействие между сетями осуществляется в соответствии с таблицей маршрутизации, управлять которой можно из меню «Routes». Маршруты в локальную сеть и к внутренним сетям провайдеров были добавлены динамически, осталось добавить маршруты в интернет (на адрес 0.0.0.0/0) через шлюзы провайдеров. Так же для обоих созданных маршрутов добавляем комментарии и указываем маршрут к 8.8.4.4 через шлюз первого провайдера (необходимо для работы проверки канала).

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/9-mikrotik-настройка-резервного-канала-в-routeros-300×236.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/9-mikrotik-настройка-резервного-канала-в-routeros.png» title=»Настройка резервного канала Mikrotik» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20315%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/9-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»Настройка резервного канала Mikrotik» width=»400″ height=»315″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/9-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/9-mikrotik-настройка-резервного-канала-в-routeros-300×236.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> Настройка резервного канала Mikrotik

7. Настройка межсетевого экрана

Используя встроенный файервол можно управлять всем трафиком, проходящем через маршрутизатор. Фильтрация осуществляется на основе правил, заданных в меню «Firewall» и применяемых последовательно ко всем сетевым пакетам. Все действия с маршрутизатором можно проводить, как из графического интерфейса, так и из командной строки. В данном разделе удобнее будет все сделать из консоли.

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/10-mikrotik-настройка-резервного-канала-в-routeros-300×236.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/10-mikrotik-настройка-резервного-канала-в-routeros.png» title=»Настройка резервного канала Mikrotik» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20315%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/10-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»Настройка резервного канала Mikrotik» width=»400″ height=»315″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/10-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/10-mikrotik-настройка-резервного-канала-в-routeros-300×236.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> Настройка резервного канала Mikrotik

Заходим в «Terminal» и выполняем следующие команды:

#скрываем внутреннюю сеть за NAT

ip firewall nat add action=masquerade chain=srcnat comment=NAT src-address=192.168.88.0/24

#запрещаем соединения со статусом invalid

ip firewall filter add action=drop chain=input comment=»Deny invalid connections» connection-state=invalid

#разрешаем использование протокола icmp

ip firewall filter add chain=input comment=»Permit icmp» protocol=icmp

#разрешаем все уже установленные соединения

ip firewall filter add chain=input comment=»Permit established connections» connection-state=established

#разрешаем все зависимые соединения

ip firewall filter add chain=input comment=»Permit related connections» connection-state=related

#блокируем все новые соединения со всех интерфейсов, кроме LAN

ip firewall filter add action=drop chain=input comment=»Deny new connections» connection-state=new in-interface=!LAN

#запрещаем ping 8.8.4.4 через ISP2

ip firewall filter add action=drop chain=output comment=»Deny 8.8.4.4 to reserved internet-channel» dst-address=8.8.4.4 out-interface=»ether2 — internet II (reserve)» protocol=»icmp»

8. Переключение каналов

В ОС роутера есть встроенная утилита «Netwatch», которая позволяет отслеживать состояние хостов в сети посредством отправки ICMP-запросов (ping) и выполнять какие-либо действия на основе их доступности. Мы будем отслеживать ip-адрес 8.8.4.4 через первый канал, и в случае его недоступности переключать маршруты на работу по второму.

Создаем новый «Netwatch host», в графе «Host» указываем отслеживаемый ip-адрес, а в «Interval» — частоту осуществляемых проверок.

» data-medium-file=»https://setiwik.ru/wp-content/uploads/2017/08/11-mikrotik-настройка-резервного-канала-в-routeros-300×260.png» data-large-file=»https://setiwik.ru/wp-content/uploads/2017/08/11-mikrotik-настройка-резервного-канала-в-routeros.png» title=»Mikrotik Настройка резервного канала в Routeros» svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20400%20346%22%3E%3C/svg%3E’ data-src=»https://setiwik.ru/wp-content/uploads/2017/08/11-mikrotik-%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D0%BE%D0%B3%D0%BE-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB%D0%B0-%D0%B2-routeros.png» alt=»Mikrotik Настройка резервного канала в Routeros» width=»400″ height=»346″ data-srcset=»https://setiwik.ru/wp-content/uploads/2017/08/11-mikrotik-настройка-резервного-канала-в-routeros.png 400w, https://setiwik.ru/wp-content/uploads/2017/08/11-mikrotik-настройка-резервного-канала-в-routeros-300×260.png 300w» data-sizes=»(max-width: 400px) 100vw, 400px»/> Mikrotik Настройка резервного канала в Routeros

В раздел «Up» нужно сделать записи:

#включим маршрут с комментарием «ISP1» (основной канал)

/ip route set [find comment=»ISP1″] disabled=no

#отключаем маршрут с комментарием «ISP2″(резервный канал)

/ip route set [find comment=»ISP2″] disabled=yes

В раздел «Down»:

#отключаем маршрут с комментарием «ISP1″(резервный канал)

/ip route set [find comment=»ISP1″] disabled=yes

#включаем маршрут с комментарием «ISP1» (основной канал)\

/ip route set [find comment=»ISP2″] disabled=no

9. Настройка безопасности

Выполняя настройку подобных устройств всегда необходимо думать о сетевой безопасности, поэтому перед введением маршрутизатора в эксплуатацию необходимо произвести следующие настройки:

  • отключить все неиспользуемые сервисы («IP» — «Services»)
  • отключить обнаружение устройства на всех внешних интерфейсах («IP» — «Neighbor»)
  • установить пароль администратора («System» — «Password»)

Mikrotik Настройка резервного канала в Routeros

Источник

Adblock
detector