Меню

Маршрутизатор cisco настройка портов



Маршрутизатор cisco настройка портов

Компания Cisco является мировым лидером в области сетевых технологий. Она смогла создать многоуровневую систему сертификации инженеров по компьютерным сетям, благодаря которой проверяются знания не только продукции, но и знание сетевых технологий, протоколов и принципов работы сети.
Маршрутизаторы Cisco используют межсетевую операционную систему — Cisco IOS, которая выполняет функции сетевой организации, маршрутизации, коммутации и передачи данных.
Интерфейс IOS имеет набор команд, доступных в зависимости от установленных привилегий для пользователя. Это позволяет избежать ошибочных действий для неподготовленных специалистов. Для использования привилегированного режима используется команда enable, для конфигурационного — команда configure terminal.

Каждый интерфейс устройств Cisco называется портом и обозначается несколькими способами:
— в фиксированных конфигурациях интерфейсы нумеруются последовательно без привязки к слоту, в который они установлены (например ethernet0, serial0).
— в модульных конструкциях с заменяемыми платами интерфейсов, используется нумерация с использованием синтаксиса типа слот/порт (например ethernet0/1, serial0/1).

Команды IOS могут предоставить пользователю информацию о конфигурации, управлении и статусе отдельных частей оборудования.

Назначение имени устройству осуществляется командой hostname

HTTP сервер как правило отключается т.к. подвержен DoS. Для этого используется команда:

Несмотря на то, что логи обычно записываются на сервер, обычно выделяют буфер в оперативной памяти размером 256 Кб в качестве резервного варианта.

Для того чтобы не вызывать перегрузку необходимо поставить ограничение: не более 10 сообщений в секунду.

Из соображений безопасности отключаем опцию IP пакета source routing

Если по маршруту есть участники с размером MTU меньше чем 1500 байт, то необходимо включить path mtu discovery

Для того, чтобы заходить на устройство по команде telnet необходимо поставить защиту. В противном случае доступ по telnet не будет получен.

Для установки пароля на привилегированный режим необходимо сделать следующее

Внутреннее время задается с помощью команды clock set. Команда вводится в привилегированном режиме.

Часовой пояс настраиваем с помощью команды clock timezone

Настройка SSH подключения

Задаем имя роутеру:
Router1(config)# hostname R1
Назначаем доменное имяЖ
R1(config)# ip domain-name name.com
Генерируем RSA ключ:
R1(config)# crypto key generate rsa
Создаем пользователя root и назначает ему пароль admin
R1(config)# username root secret admin
создаем access-list, в котором можем задать например с каких IP адресов мы можем подключиться:
R1(config)# access-list 1 permit 10.1.1.12
Настраиваем виртуальный терминал с 0 по 4 и задаем проверку пароля локально
R1(config)# line vty 0 4
R1(config)# login local
С помощью списка доступа разрешаем доступ с IP-адреса
R1(config)# access-class 1 in
И разрешаем работать по протоколы SSH
R1(config)# transport input ssh
R1(config)# transport output ssh
R1(config)# end

Настройка NAT

Настраиваем интерфейс, который смотрит в интернет
interface FastEthernet0/0
ip nat outside
На локальном интерфейсе
interface vlan1
ip nat inside
Создаем список IP-адресов, имеющих доступ к NAT
ip access-list entended NAT
permit ip host 192.168.xxx.xxx any
Включаем NAT (PAT) на внешнем интерфейсе
ip nat inside source list NAT interface FastEthernet0/0 overload
И добавляем инспекцию протоколов
ip inspect name INSPECT_OUT http
ip inspect name INSPECT_OUT https
ip inspect name INSPECT_OUT ftp

Раздаем адреса по DHCP

Сохранение настроек роутера
Для того чтобы не повредить конфигурационные файлы после выключения устройства можно сделать сохранение настроек командой copy running-config startup-config

Просмотр интерфейса show interfaces

Позволяет просмотреть статус всех интерфейсов на устройстве. Если указать конкретный порт, то отобразится информация только по указанному интерфейсу. Например:

Основная полученная информация
  • FastEthernet0/0 is up, line protocol is up (connected) — порт включен и получает сигнал от подключенного к нему кабеля.
  • Hardware is Lance, address is 0030.a399.3901 (bia 0030.a399.3901) — информация о модели интерфейса и его физическом адресе
  • Encapsulation ARPA, loopback not set — указывает тип инкапсулирования для данного интерфейса.

Если инкапсулирование данных для интерфейсов локальной сети не нуждается в настройке, то для интерфейсов глобальных сетей это необходимо.

Интерфейс может быть в различном состоянии:
— «UP» — включен, поднят
— «DOWN» — выключен, нет линка
— «Administratively down» — административная блокировка
Различие заключается в том, что отключенный интерфейс находится в рабочем состоянии, но не обменивается данными с подключенной к нему средой, а в состоянии административной блокировки интерфейс отключен на уровне конфигурации.

Читайте также:  Не сохраняются настройки amd catalyst control center

Пример административной блокировки порта

Настройка интерфейса Ethernet

Заходим на интерфейс
router (config)# interface fastethernet 0/1
Устанавливаем IP на интерфейс
router (config)# ip add 10.0.0.1 255.255.255.0
Поднимаем интерфейс
router (config)# no shutdown

Посмотреть какой IP-адрес назначен интерфейсу можно командой show ip interface

Настройка интерфейса Serial

Заходим на интерфейс
router (config)# interface serial 0/0/0
Устанавливаем IP на интерфейс
router (config)# ip add 192.168.1.1 255.255.255.0
Устанавливаем скорость порта
router (config)# clock rate 56000
Поднимаем интерфейс
router (config)# no shutdown

Команда encapsulation определяет тип протокола канального уровня и формат передаваемых данных для конкретного интерфейса. Например:

Отключение порта shutdown

Команды выключения/включения интерфейса применяется, если необходимо изменить административное состояние интерфейса. Оборудование Cisco не передает данные на интерфейс, если он заблокирован на административном уровне. Выключение порта осуществляется путем входа на нужный интерфейс и ввода команды shutdown. Например:

Проверяем полученный результат с помощью уже известной команды show interfaces:

Включение интерфейса осуществляется командой no shutdown

Добавление описания/комментария с помощью команды description
К каждому из доступных интерфейсов доступно поле длиной не более 255 символов.

Просмотр информации о VLAN

Команда show vlan позволяет посмотреть информацию о созданных виртуальных каналах.

В рабочих конфигурациях использование VLAN с номером 1 не рекомендуется.

Команды конфигурирования IP-маршрутизации

Для просмотра таблицы IP-маршрутизации используется команда show ip route

Результаты данной команды дают администратору сети огромное количество данных. Они являются ключевым инструментом для определения пути, по которому пакет проходит по сети.
В приведенном выше примере строка Gateway of last resort — это сетевой адрес маршрутизатора, куда должны будут посылаться пакеты, имеющие пункт назначения вне данной сети. Если статические маршруты и протоколы динамической маршрутизации не заданы, то будет указано «is not set». После представлена сама таблица маршрутизации. Буква перед маршрутом означает код, пояснения к которому выводятся выше.

Команды для конфигурирования служб имен доменов

Большинство пользователей обращаются к серверам, рабочим станциям и другим IP-устройствам, используя их имя, а не IP-адрес. Роль преобразования IP-адреса в имя отводится DNS серверам. Маршрутизаторы также могут пользоваться DNS-системой для преобразования имен в IP-адреса.

Пример конфигурирования службы DNS маршрутизатора:

Проверка установок службы DNS на маршрутизаторе выполняется с помощью команды show host

Сброс настроек к первоначальным

На маршрутизаторах Cisco по команде

на маршрутизаторах Cisco Catalyst:

it_donnet

Блог о сетевых устройствах, тестировании различных устройств. На сайте вы найдете инструкции для настройки различных устройств. А раздел «Путешествие» поможет познакомиться с интересными местами.

Источник

Начальная настройка маршрутизатора Cisco. Доступ в Интернет.

Read the article BASIC CONFIGURATION OF THE CISCO ROUTER. ACCESS TO THE INTERNET in English

Рассмотрим схему подключения офиса к сети Интернет с помощью маршрутизатора Cisco. Для примера возьмем модель Cisco 881. Команды для настройки других маршрутизаторов (1841, 2800, 3825…) будут аналогичными Различия могут быть в настройке интерфейсов, вернее в их названиях и нумерации.

В схеме присутствуют:

  • канал в Интернет со статическим адресом
  • несколько компьютеров в локальной сети офиса
  • маршрутизатор
  • коммутатор, который используется для организации локальной сети офиса

Задача: обеспечить доступ компьютеров локальной сети в Интернет.

Читайте также:  Настройка режима обычной загрузки

Шаг 0. Очистка конфигурации

Первое, с чего стоит начать настройку нового маршрутизатора – полностью очистить стартовую конфигурацию устройства. ( Выполнять только на новом или тестовом оборудовании! ) Для этого нужно подключиться с помощью специального кабеля к консольному порту маршрутизатора, зайти в командную строку и выполнить следующее:

Войти в привилегированный режим(#), возможно потребуется ввести логин/пароль.
router> enable
Удалить стартовую конфигурацию
router# write erase
/подтверждение/
Перезагрузить маршрутизатор
router# reload
/подтверждение/
После выполнения маршрутизатор должен перезагрузиться в течение 3ех минут, а при старте вывести запрос о начале базовой настройки. Следует отказаться.
Would you like to enter the basic configuration dialog (yes/no): no
В текущей конфигурации маршрутизатора будут только технологические строки по умолчанию, и можно приступать к основной настройке.

Шаг 1. Имя устройства

Задание имени маршрутизатора для удобства последующего администрирования выполняется командой hostname «название устройства»
router# conf t
router (config)# hostname R-DELTACONFIG
R-DELTACONFIG (config)#

Шаг 2. Настройка интерфейсов

Необходимо настроить 2 интерфейса: внешний и внутренний.
Через внешний интерфейс будет осуществляться связь с Интернет. На нем будут те ip адрес и маска сети, которые предоставил Интернет провайдер.
Внутренний интерфейс будет настроен для локальной сети 192.168.0.0 /24

Предположим, что оператор связи предоставил нам следующие адреса:

  • Сеть 200.150.100.0
  • Маска подсети 255.255.255.252 или /30
  • Шлюз по умолчанию 200.150.100.1

Настроим внешний интерфейс: зададим ip адрес и сетевую маску, и включим его командой no shut
R-DELTACONFIG#conf t
R-DELTACONFIG (config)#
interface Fa 4
ip address 200.150.100.2 255.255.255.252
no shutdown
После этого соединяем этот интерфейс маршрутизатора с портом оборудования провайдера при помощи прямого патч корда и далее проверяем его доступность командой ping.

Сначала собственный интерфейс
R-DELTACONFIG# ping 200.150.100.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.150.100.2, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 1/1/4 ms
Затем соседний адрес — шлюз провайдера
R-DELTACONFIG# ping 200.150.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.150.100.1, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 2/4/10 ms
Убедившись в доступности шлюза Провайдера, переходим к настройке внутреннего интерфейса.

В локальной сети будет использоваться следующая адресация

  • Сеть 192.168.0.0
  • Маска подсети 255.255.255.0
  • Внутренний адрес маршрутизатора, который выполняет роль шлюза в Интернет для всех хостов в сети, 192.168.0.1
  • Диапазон внутренних адресов сети (пользователи, принтеры, серверы и.т.д.) советую начинать с адреса 192.168.0.5
  • Максимально возможный доступный для использования адрес в этой сети будет 192.168.0.254
  • Адреса с 192.168.0.2 до 192.168.0.4 оставим про запас для непредвиденных технологических нужд

Для настройки внутреннего интерфейса локальной сети следует зайти в режим конфигурирования виртуального интерфейса Vlan 1, задать на нем ip адрес и соотнести ему один из физических интерфейсов маршрутизатора (Fa 0).
R-DELTACONFIG#conf t
interface Vlan 1
Ip address 192.168.0.1 255.255.255.0
no shutdown
Выбираем физический интерфейс маршрутизатора и соотносим его с виртуальным Vlan
interface Fa 0
switchport access vlan 1
no shutdown
Для наглядности:

ip address => interface Vlan X => interface Fastethernet Y
Ip адрес присваивается виртуальному интерфейсу Vlan X, а он привязывается к физическому интерфейсу Fastethernet Y.

Интерфейс маршрутизатора Fa 0 нужно соединить с коммутатором, где располагаются рабочие станции локальной сети или напрямую с рабочей станцией администратора. После этого проверить доступность этого интерфейса маршрутизатора с помощью ping из командной строки.

Шаг 3 Настройка удаленного доступа к маршрутизатору

Получить доступ к консоли маршрутизатора можно не только с помощью консольного кабеля, но и удаленно с помощью протоколов Telnet(данные передаются в открытом виде) или SSH(защищенное соединение).
Рассмотрим настройку безопасного подключения.
Включаем протокол SSH 2 версии и задаем произвольное имя домена
R-DELTACONFIG (config)#
ip ssh ver 2
ip domain-name xxx.ru
Генерируем ключи rsa, необходимые для подключения. При запросе указываем 1024.
crypto key generate rsa
How many bits in the modulus [512]: 1024
Задаем имя пользователя с правами администратора и его пароль (*****)
username admin privilege 15 secret 0 *****
Включаем авторизацию через локальную базу устройства (тот пользователь, которого создали строчкой выше)
line vty 0 4
login local
Задаем пароль на привилегированный режим
enable secret 0 *****
После этого при помощи специальной программы, поддерживающей протокол SSH можно зайти в командную строку маршрутизатора удаленно с любой из рабочих станций локальной сети. При авторизации следует ввести логин и пароль, которые были задан. Подробнее про доступ на устройство по протоколу SSH написано в этой статье.

Читайте также:  Huawei honor 4c настройки звука

Шаг 4. Шлюз по умолчанию

Для маршрутизации пакетов в сеть Интернет на устройстве необходимо указать шлюз по умолчанию(default gateway).
R-DELTACONFIG (config)#
ip route 0.0.0.0 0.0.0.0 200.150.100.1
После этого можно проверить не только доступность оборудования провайдера, но и полностью канала в Интернет. Для этого необходимо запустить ping до любого адреса во внешней сети в цифровой форме(DNS для локальной сети лучше настраивать после настройки маршрутизатора). Для примера возьмем адрес лидера на рынке ping – www.yandex.ru (93.158.134.3)
R-DELTACONFIG#ping 93.158.134.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 93.158.134.3, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 1/5/10 ms

Важно!
Обратите внимание, что на данный момент ping внешних адресов работает только(!) будучи запущенным из консоли управления маршрутизатором. Рабочие станции локальной сети все еще не имеют доступа в Интернет.

Шаг 5 Настройка трансляции адресов (NAT)

Для доступа в Интернет из локальной сети необходимо динамически транслировать все внутренние адреса в определенный внешний ip адрес. В нашем случае, так как провайдер предоставляет только один внешний адрес 200.150.100.2 (определяется маской подсети /30 в условиях примера), то все адреса локальной сети должны транслироваться в него.
Указываем список внутренних адресов, которые будем транслировать во внешний адрес.
R-DELTACONFIG (config)#
ip access-list standard ACL_NAT
permit 192.168.0.0 0.0.0.255
Указываем внутренний интерфейс для процедуры трансляции
Interface Vlan 1
ip nat inside
Указываем внешний интерфейс для процедуры трансляции
Interface Fa 4
ip nat outside
Создаем правило трансляции (NAT)
ip nat inside source list ACL_NAT interface fa4
В результате должен появиться доступ с любой рабочей станции локальной сети в Интернет при условии, что шлюзом по умолчанию указан внутренний ip адрес маршрутизатора (192.168.0.1). Проверить можно с помощью команды ping до адреса в Интернет из командной строки. Желательно, чтобы проверяемый адрес был в цифровом виде, чтобы исключить потенциальные проблемы с DNS именами.

Важно!
В указанном примере меняется собственный адрес источника. Если в процессе работы необходимо транслировать адрес назначения — пускать траффик на вымышленный адрес, чтобы попасть на некий настоящий, то прочитайте статью ip nat outside.

Важно!
Не стоит оставлять полный доступ в Интернет со всех адресов локальной сети. Советую после проверки работоспособности соединения для безопасности ограничить доступ в Интернет и разрешить его только с конкретных адресов — например с прокси сервера и рабочих станций администратора и/или директора. О том как это сделать можно прочитать в статье «немного об access lists«.

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
R-DELTACONFIG# write
Building configuration.
[OK]

Источник

Adblock
detector