Меню

Коммутатор cisco первоначальная настройка



Первичная настройка коммутатора Cisco.


Циска поприветствует вас вопросом, а не хотим ли мы начать диалог конфигурирования?

Строго говорим no, мы будем настраивать всё вручную.
После заходим в enable-режим.

Теперь циска позволит зайти нам в режим конфигурации командой configure terminal. Мы люди ответственные, поэтому первым делом настроим безопасность, создадим юзера и навесим пароль для него. Пользователь будет admin, вместо [password] введите пароль.

privelege — уровень доступа для конкретного пользователя, может быть от 0 до 15.
secret — зашифрует пароль в виде MD5-хеша, пользуйтесь именно этим способом.
password — модификатор, который не будет скрывать пароль, он так и будет храниться в конфиге в «голом» виде, что небезопасно.
Сразу зададим пароль для режима enable:

Создадим для начала пользователя с порезанными правами. В нашем примере это будет user с паролем 12345678.

Теперь нам надо задать пароль для привилегированного enable-режима с доступом level 3. Не будем мудрствовать лукаво и сделаем его password.

Теперь давайте разберемся, какие команды нужно разрешить использовать на этом уровне доступа для выполнения поставленной задачи.
В CLI-моде нашему товарищу нужно мочь перейти в режим конфигурации, посмотреть и сохранить текущий конфиг.

В режиме же конфигурирования потребуется разрешение на переход к настройке интерфейса.

А уже в режиме конфигурации интерфейса надо разрешить возможность отключения интерфейса и смену voice VLAN.

Сейвимся и проверяем.

Поехали дальше. Теперь нам нужно настроить aaa (происходит от authentication, authorization, accounting):

Сразу не отходя от кассы настроим работу через telnet.

Что еще. Точно, коммутатору же будет явно грустно без навешенного на интерфейс IP-адреса! Без этого его потом удаленно не получится конфигурить и просто заниматься мониторингом.
На коммутаторе уже присутствует дефолтный влан, использующийся по-умолчанию для управления, но давайте сразу пойдем более сложным путем и вынесем управление в отдельный влан.
Пусть это будет VLAN 177. Создадим его на коммутаторе и добавим в него нужные порты.

По ходу пьесы мы создали 177-ой влан, назвали его «Management-vlan» и добавили аксессом на порт gi1/0/25.
Осталось задать коммутатору IP из этого VLAN. Например, 172.16.99.99/24:

Теперь нюанс. Если машина, с которой вы хотите управлять коммутатором, находится в той же подсети, то больше настраивать ничего не нужно. Другое дело, если коммутатор и другой хост разнесены по разным подсетям. Маршрутизирует их, понятное дело, какой-то роутер, поэтому требуется указать адрес его шлюза.

Проверим, доступен ли коммутатор через telnet, если да, то остальную конфигурацию будем делать уже удаленно.

Можно настроить время на коммутаторе. Если в вашей сети есть NTP-сервер, то укажите его адрес. Например, 172.16.99.2:

Еще можно задать коммутатору имя, оно же hostname:

Назвать его можно как угодно, но лучше пусть это будет что-то информативное.

Сохраняем наш конфиг.

Решил сюда же до кучи добавить активно юзающиеся команды, которые точно вам пригодятся.
# show running-config — показывает текущий конфиг
# show startup-config — показывает стартовый конфиг
# show version — показывает модель циски, версию Cisco IOS и прочую инфу
# show interfaces status — статус интерфейсов
# show ip route — таблица маршрутизации
# show cdp neighbors — показывает соседей по протоколу CDP (аналогично для OSPF, EIGRP, etc.)
# terminal monitor — выводит сообщения лога прямо в терминале (каретку лучше в начало строки перевести)
# show inventory — показывает инфу по дополнительным железкам в вашей циске — платам/SFP-модулям и прочему
# show mac address-table — показывает MAC-таблицу устройства. Можно посмотреть её для определенного VLAN show mac address-table vlan 23 или конкретного физического интерфейса show mac address-table interface gigabitEthernet 1/0/3. Также этой командой можно найти конкретный MAC-адрес show mac address-table address AA:BB:CC:DD:EE:FF. С помощью специального модификатора можно запустить поиск по известной части MAC-адреса show mac address-table | include 01AB, и еще кучу всего (подробнее в справке для | Output modifiers)
# show processes cpu sorted — показывает нам загрузку CPU как-то так CPU utilization for five seconds: 45% / 0% ; one minute: 48%; five minutes: 46%, где красным отображается общая загрузка, а синим — загрузка прерываниями.
# show ip interface brief — показывает информацию об IP интерфейсов.

Читайте также:  Kate mobile не могу найти настройки

Источник

Простейшая настройка коммутатора Cisco 2960

Read the article BASIC CONFIGURATION OF CISCO 2960 SWITCH in English

Рассмотрим простейший случай, когда требуется подключить 3 отдела фирмы в разные логические сети Vlan, используя один коммутатор уровня доступа Cisco 2960 (Иногда такие коммутаторы называются коммутаторами 2го уровня модели OSI) .

Требуется организовать следующие сети (Vlan):

— отдел продаж (192.168.10.0 255.255.255.0)
— бухгалтерия (192.168.20.0 255.255.255.0)
— администраторы (192.168.100.0 255.255.255.0)
— сеть для управления сетевым оборудованием (192.168.1.0 255.255.255.0)

Видео версия этой статьи на английском языке.

Для справки:
Устройства 2го уровня способны передавать данные только внутри одной сети и осуществляют передачу на основе информации о MAC адресах (например внутри сети 192.168.0.0 /24).

Устройства 3го уровня (например коммутатор Cisco 3560) способны маршрутизировать данные на основе информации об ip адресах и передавать их между различными сетями (например между сетью 192.168.1.0 /24 и сетью 192.168.2.0 /24).

Шаг 0. Очистка конфигурации

(Выполняется только с новым или тестовым оборудованием, так как ведет к полному удалению существующей конфигурации)

После извлечения коммутатора из коробки, подключаемся к нему с помощью консольного кабеля и очищаем текущую конфигурацию, зайдя в привилегированный режим и выполнив команду write erase. (Подробнее о режимах конфигурирования оборудования Cisco можно прочитать в этой статье)

Switch> enable
Switch# write erase
/подтверждение очистки конфигурации/
Switch# reload
/подтверждение/
После выполнения коммутатор должен перезагрузиться в течение 3ех минут, а при старте вывести запрос о начале настройки. Следует отказаться.
Would you like to enter the basic configuration dialog (yes/no): no

Шаг 1. Имя коммутатора

Присвоим коммутатору имя SW-DELTACONFIG-1. (SW – сокращение названия SWitch) Для этого зайдем в режим конфигурирования и введем следующие команды:

Читайте также:  Настройка airport на маке

Switch #conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch (config)# hostname SW-DELTACONFIG-1
SW-DELTACONFIG-1 (config)#
Название устройства изменилось со «Switch» на «SW-DELTACONFIG-1».

Шаг 2. Интерфейс для удаленного управления

Настраиваем интерфейс для управления коммутатором. По умолчанию это Vlan 1. Для этого присваиваем ip адрес интерфейсу и включаем его командой no shutdown.

SW-DELTACONFIG-1(config)#
interface vlan 1
ip address 192.168.1.11 255.255.255.0
no shutdown
В дальнейшем коммутатор будет доступен именно под адресом 192.168.1.11

Шаг 3. Авторизация пользователей

Настраиваем авторизацию для доступа к устройству. Для этого задаем пароль доступа к привилегированному режиму (знак # рядом с названием устройства), а также создаем учетную запись пользователя и пароль для удаленного подключения.

Задаем пароль для доступа к привилегированному режиму #
SW-DELTACONFIG-1(config)#
enable secret XXXX

Создаем учетную запись для удаленного управления и пароль для нее
username admin secret YYYYY

Включение авторизации, с использованием локальной базы данных пользователей и паролей
SW-DELTACONFIG-1(config)#
line vty 0 4
login local

Для проверки доступности enable режима (#) после ввода этих команд выходим из всех режимов конфигурирования (командой exit или буквой Q в каждом из режимов или сочетанием клавиш Ctrl+Z), оказываемся в первоначальном режиме (обозначается знаком >) и пробуем вновь зайти в привилегированный режим (обозначается знаком #). На запрос пароля вводим тот, который только что задали.

Если ничего не напутали, то видим примерно следующее:
SW-DELTACONFIG-1>enable
Password: XXXXX
SW-DELTACONFIG-1#

Проверку удаленного доступа можно осуществить , запустив из командной строки рабочей станции команду telnet 192.168.1.11. Должен появиться диалог запроса логина и пароля.

После того, как убедитесь, что устройство доступно по протоколу Telnet рекомендую настроить защищенный доступ по протоколу SSH. Подробные инструкции приведены в этой статье.

Шаг 4. Создание Vlan

Создаем Vlan для каждого из отделов и присваиваем им порядковые номера и названия.
SW-DELTACONFIG-1(config)#
vlan 10
name NET_SALES
vlan 20
name NET_ACCOUNT
vlan 100
name NET_ADMIN

Сеть Vlan 1 всегда присутствует на коммутаторе по умолчанию. Она будет использоваться для удаленного управления.

Проверить текущие настройки Vlan можно, выполнив команду sh vlan:
SW-DELTACONFIG-1# show vlan
VLAN Name Status Ports
—- ——————— ——— ——————————-
1 default active Fa0/1, Fa0/2, /. вырезано. /
10 NET_SALES active
20 NET_ACCOUNT active
100 NET_ADMIN active

Убеждаемся, что все созданные нами сети присутствуют в списке.

Шаг 5. Привязка портов

Соотносим порты доступа коммутатора (access port) нужным сетям. На коммутаторе из примера 24 порта FastEthernet и 2 порта Gigabit Ethernet. Для подключения пользователей будут использоваться только Fast Ethernet.

Распределим их следующим образом:

  • первые 6 из них в сеть администраторов (Vlan 100)
  • 12 в сеть отдела продаж (Vlan 10)
  • 6 следующих в сеть для бухгалтерии (Vlan 20).
Читайте также:  Настройка пульта dsp 0501

На каждом интерфейсе для удобства дальнейшего администрирования добавим примечания командой description. Это обычное текстовое поле, которое никак не влияет на другие настройки.
SW-DELTACONFIG-1(config)#
interface range fa 0/1 – 6
switchport access vlan 100
description NET_ADMIN
interface range fa 0/7 – 18
switchport access vlan 10
description NET_SALES
interface range fa 0/19 – 24
switchport access vlan 20
description NET_ACCOUNT

После этого рядом с каждым Vlan будут указаны принадлежащие ему порты, а вывод команды sh vlan должен стать примерно таким:
SW-DELTACONFIG-1# show vlan
VLAN Name Status Ports
—- —————- ——— ——————————-
1 default active
10 NET_SALES active Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18
20 NET_ACCOUNT active Fa0/19, Fa0/20, Fa0/21, Fa0/22, Fa0/23, Fa0/24
100 NET_ADMIN active Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6

Введенными командами мы разделили один физический коммутатор на 4 логических (Vlan 1, Vlan 10, Vlan 20 и Vlan 100).

Важно!
Взаимодействие без использования маршрутизатора будет осуществляться только(!) между портами, принадлежащими одному и тому же Vlan.
Рабочие станции, подключенные в порты, принадлежащие разным Vlan, не смогут взаимодействовать друг с другом даже если будет настроена адресация из одной сети.

Для взаимодействия всех 4ех сетей необходим маршрутизатор, подключенный к коммутатору с помощью trunk порта. Инструкцию по настройке вы найдете здесь. Отличие trunk интерфейса в том, что при передаче по нему трафика каждый пакет помечается номером Vlan, которому принадлежит. Это позволяет устройствам правильно перенаправлять пакеты. На самом коммутаторе порт настраивается следующим образом:
SW-DELTACONFIG-1(config)#
interface GigabitEthernet 0/1
switchport mode trunk
switchport trunk encapsulation dot1q

Если система не принимает последнюю строчку, то это значит, что режим dot1q – единственно возможный, и он настроен по умолчанию.

После выполнения всех описанных действий для проверки подключите две рабочие станции в порты, принадлежащие одному Vlan, например с номером 100, установите на них ip адреса 192.168.100.1 и 192.168.100.2, после чего запустите ping с одной из них на другую. Успешный ответ означает, что все работает как нужно.
Для справки:
Существуют модели коммутаторов 3го уровня модели OSI (Например Cisco 3560), которые объединяют в себе функции коммутатора 2го уровня (access или уровня доступа) и маршрутизатора (устройства 3го уровня). Устройства 3го уровня используются для передачи данных между различными сетями и руководствуются информацией об ip адресах.

Решение аналогичной задачи организации нескольких Vlan на таком коммутаторе рассмотрено в этой статье)

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
FW-DELTACONFIG-1# write
Building configuration.
[OK]

Источник

Adblock
detector