Меню

Cisco настройка dhcp pool



Настройка DHCP сервера в CISCO ­ Дневник ­ Максим Боголепов

Настройка DHCP сервера в CISCO

В данной заметке опишу пошаговую настройку сервиса DHCP в маршрутизаторах CISCO . Нижеследующее точно будет справедливо для устройств 800, 1800, 2800 серии. Именно такие CISCO находятся в моем ведении и данная конфигурация работает со стопроцентной гарантией.
Сразу сделаю оговорку, что в статье описывается только процесс настройки именно DHCP сервиса. Вопросы маршрутизации и общей безопасности затрагиваться не будут.

В подготовительных действиях мы отключим вывод логов на консоль и настроим сетевой интерфейс FastEthernet0/1 , разбив его на два vlan’а. На интерфейсе FastEthernet0/1.1 будет настроен нативный vlan основной подсети 192.168.100.0/22, на интерфейсе FastEthernet0/1.2 будет настроен vlan тестовой подсети 172.16.0.0/24:

Приступим к непосредственно настройке сервиса DHCP :

1. на всякий случай данной командой мы включим необходимый нам сервис;
2. обозначим пул для нашей основной сети организации;
3. команда предназначено для импорта всех настроек в базу данных сервера DHCP ;
4. обозначим нашу сеть;
5. укажем доменное имя нашей компании;
6. данной командой пропишем существующие DNS сервера в нашей сети;
7. данной командой пропишем существующие WINS сервера в нашей сети;
8. обозначим шлюз по умолчанию в нашей сети (это наша CISCO );
9. следующие три строчки отдадут клиентским компьютерам необходимые нам опции:
— option 4 – укажет ip адрес Time Server в нашей сети;
— option 42 – укажет ip адрес NTP Servers в нашей сети;
— option 150 – укажет нашим CISCO телефонам расположение TFTP сервера в сети для их конфигурации;
(более подробно о возможных опциях можно почитать тут).
10. командой lease укажем срок действия выданного ip адреса;
11. и наконец – включим обновление ARP таблицы в соответствии с выданным ip адресом;
12. выйдем из настройки нашего пула для основной сети…

1. укажем диапазон исключаемых из выдачи ip адресов (куда обязательно должен входить ip адрес нашего шлюза). я использую данный диапазон для серверов и различных сетевых устройств;
2. списков исключения может быть несколько (данный я использую для хостов, имеющих полный доступ в интернет – 192.168.103.80/28);
3. отключим использование VRF на интерфейсе, принимающем запросы на выдачу ip адреса;
4. обозначим местоположение базы данных DHCP . в принципе ее можно хранить и на flash CISCO ;
5. данная настройка позволит обновлять обе (прямую и обратную) записи A и RTP на нашем сервере DNS ;
6. отключим использование BOOTP (Bootstrap Protocol — протокол начальной самозагрузки) сервиса;
7. выполним сохранение наших настроек.

В сети существует следующая рекомендация: при настройке DHCP сервера на CISCO , не являющейся роутером по умолчанию в вашей сети, в настройках интерфейса в роутере по умолчанию нужно указать опцию ip helper-address IP_ADDRESS , где IP_ADDRESS – адрес настраиваемой вами CISCO с DHCP сервером.

База данных сервиса DHCP имеет следующий вид:

Просмотреть информацию о ней можно командой sh ip dhcp database :

Информация о работающем DHCP можно просмотреть командой sh ip dhcp server statistics :

Аналогичным образом настроим пул для тестовой подсети 172.16.0.0/24:

Осталось показать каким образом настраивать резервирование. Просмотреть все выданные ip адреса можно командой sh ip dhcp binding :

Как видно, здесь показаны как автоматически, так и вручную настроенные привязки mac-адреса к ip.
Чтобы сделать привязку вручную, необходимо:

1. обозначим новый пул с произвольным именем;
2. укажем назначаемый ip адрес и маску подвести;
3. пропишем mac адрес, начиная с 01 ;
4. присвоим имя для настраиваемого хоста (без доменного суффикса);
5. осуществим выход из настройки пула и сохранение наших настроек:

Если в момент указания client-identifier у вас выскочит ошибка вида % A binding already exists for 172.16.0.36. , вам необходимо сперва очистить в режиме enable уже существующую привязку для этого хоста командой clear ip dhcp binding :

Читайте также:  Zte blade af5 настройки

Вот и все. Приведу теперь листинг нашей проделанной работы:

Rating: 4.5/5(10 votes cast)

Источник

Урок 40. Принцип работы и настройка DHCP на Cisco роутере

Принцип работы DHCP

Чтобы компьютеры работали в сети им как минимум нужно настроить следующие параметры:

  • IP адрес
  • Маску подсети
  • Шлюз по умолчанию
  • DNS сервер

Само собой обычный пользователь даже не знает, что что-то подобное существует и уж тем более как все это настроить. А для администратора это нудное и утомительное занятие, особенно когда в сети 100 и более компьютеров.

На помощь приходит технология DHCP (Dynamic Host Configuration Protocol). Суть ее работы заключается в том, в сети присутствует DHCP сервер, который хранит и выдает сетевые настройки при обращении к нему сетевых устройств, которые называются DHCP клиенты.

Хост, который не имеет сетевой конфигурации отправляет широковещательный запрос. На этот запрос реагирует только DHCP сервер. Принцип работы выглядит следующим образом:

А вот как выглядит этот процесс в программе Wireshark:

Обычно в сети имеется один DHCP сервер, однако в больших корпоративных сетях используют 2 и более серверов. Они могут работать по принципу master-slave либо независимо друг от друга и обслуживать отдельные сегменты сети.

В небольших сетях роль DHCP сервера, как правило, берет на себя сам маршрутизатор.

Настройка сервера DHCP

DHCP сервер может быть запущен как на отдельном специализированном сервере (обычно под управлением Linux или Windows) либо на маршрутизаторе.

Рассмотрим настройку на роутере. Компания Cisco рекомендует использовать специальные хосты, называемые DHCP database agent (агент, хранящий базу данных DHCP, то есть таблицу назначенных IP адресов и необходимые параметры). В качестве хранилища выступает сервер FTP/TFTP.

Для чего необходимо данное устройство? Может ли роутер хранить свою базу данных локально?

Конечно же может. Однако при перезагрузке маршрутизатора все данные теряются и ему будет сложнее решать конфликтные ситуации, когда хосту нужно выделить адрес, а он уже занят другим устройством.

При наличии отдельно хранящейся базы данных маршрутизатор после перезагрузки сможет получить необходимые данные и корректно управлять процессом раздачи.

Что произойдет, если в сети устройству статически настроили адрес, а роутер захочет назначить его другому устройству?

Перед тем, как назначить выбранный адрес, сервер всегда посылает Echo Request (Ping) по данному адресу. Если адрес “молчит”, то он свободный, в противном случае адрес временно удаляется из пула и выбирается новый.

Чтобы DHCP сервер работал сначала настроим и включим интерфейс локальной сети. Интерфейс должен иметь адрес, потому что маршрутизатор будет раздавать адреса только на том интерфейсе, чей адрес соответствует адресам пула.

Если мы собираемся использовать Database agent, то для него необходимо настроить сетевой путь в нашем сервере:

Router(config)#ip dhcp database сетевая_ссылка_к_агенту [timeout секунды | write-delay секунды]

Если агента базы данных нет, то отключаем логирование конфликтных событий:

Router(config)#no ip dhcp conflict logging

Делается это для того, чтобы роутер не исключал адреса из пула при возникновении коллизий. Если такие коллизия случаются часто, то это может исчерпать весь пул адресов (конфликтные адреса будут просто удалены из пула) и администратору придется вручную устранять проблемы. Поэтому на всякий случай отключаем логирование.

Теперь мы готовы создать и сам пул адресов:

Router(config)# ip dhcp pool имя

Вводим основные параметры сети:

Router(dhcp-config)# network адрес_сети маска

Router(dhcp-config)# default-router адрес_роутера

Router(dhcp-config)# dns-server адрес_сервера

Следует знать, что IP адрес выдается на временное пользование. По истечении срока аренды (lease time) хост должен снова запросить адрес. Срок аренды можно настроить параметром:

Читайте также:  Спутник абс 2 настройка ресивера

Router(dhcp-config)# lease 2 (в днях)

Можно ли настроить несколько пулов?

Да, можно, например, для разных VLAN.

Можно ли исключить из раздачи определенные адреса?

Да, можно. Делается это так:

Router(config)# ip dhcp excluded-address начальный_адрес конечный_адрес

С помощью вышеуказанной команды мы исключаем сразу несколько адресов с начального по конечный.

Если же адреса разрозненны и не получается выделить начальный и конечный адреса, то можно исключить их по одному. Например, так:

Router(config)# ip dhcp excluded-address 192.168.1.13

Router(config)# ip dhcp excluded-address 192.168.1.28

Router(config)# ip dhcp excluded-address 192.168.1.145

Помимо перечисленных выше параметров DHCP поддерживает и другие параметры, например, имя домена, адрес FTP/TFTP серверов, статический маршрут и так далее.

Просмотр сведений о DHCP

После того, как сервер настроен и работает самое время проверить его работу, а также конфликты.

R outer# show ip dhcp pool название

Список уже назначенных адресов, время аренды, МАС адреса узлов:

Router# show ip dhcp binding

Список конфликтных (удаленных из пула) адресов:

Router# show ip dhcp conflict

База данных DHCP:

R outer# show ip dhcp database

Статистика работы сервера:

Router# show ip dhcp server statistics

Статическая привязка адреса

Иногда может понадобиться статическая привязка адреса к определенному компьютеру. Для этого создадим отдельный пул, в котором укажем IP и МАС адреса хоста:

Router(config)# ip dhcp pool имя

Router(dhcp-config)# host IP_адрес

Router(dhcp-config)# client-identifier идентификатор_хоста

Что такое идентификатор хоста?

Некоторые хосты при запросе адреса посылают серверу свой идентификатор, который передается в опции 61 (Option 61).

Что из себя представляет идентификатор?

Он состоит из 2-х частей: типа интерфейса и МАС адреса хоста. Например, хост имеет МАС адрес 00:50:79:66:68:00 и работает в Ethernet сети. Тогда его идентификатор будет равен 0100.5079.6668.00, где первые 2 цифры 01 указывают на тип интерфейса Ethernet, а остальные — на МАС адрес хоста.

Увидеть идентификатор можно в самом роутере с помощью отладчика пакетов DHCP сервера, а также в сетевом дампе. Отладчик можно запустить командой

Router# debug ip dhcp server packet

Вот как будет выглядеть идентификатор в отладчике и Wireshark:

Отладчик

Wireshark

Однако не все хосты отправляют свой идентификатор в DHCP запросе, поэтому вместо команды client-identifier можно воспользоваться другой командой:

Router(dhcp-config)# hardware-address МАС_адрес

Следует учитывать следующее:

  • Для каждого адреса создается отдельный пул, то есть, если у нас 10 адресов, то нужно создать 10 пулов.
  • В статическом пуле нельзя применять команду network . Для этого необходимо создавать отдельный пул.

Статическая привязка адреса через текстовый файл

Если нужно настроить большое количество хостов со статически привязанными адресами, то создавать отдельный пул для каждого из них задача довольно утомительная. Для упрощения процесса можно создать текстовый файл, в котором укажем IP и МАС адреса.

Этот файл можно хранить как на отдельном TFTP/FTP сервере, так и в самом роутере.

При запуске DHCP службы маршрутизатор скачает файл и обновит свою базу данных.

Как же выглядит файл?

Файл выглядит так:

Что означает поле Type?

Type означает тип интерфейса. Например, если у нас Ethernet, то указываем 1. В нашем файле в качестве Type мы указали значение id, что означает идентификатор клиента. Дело в том, что если хост использует в запросе client-identifier, то в файле тоже необходимо указать его значение. Если же хост не использует идентификатор, то указываем 1 и его МАС адрес.

Теперь поговорим о самой настройке. Она очень проста. Достаточно выполнить следующие команды:

R outer(config)# ip dhcp pool имя

Источник

Настройка DHCP Cisco

Протокол DHCP позволяет производить автоматическую настройку сетевых устройств. Настройка DHCP сервера на маршрутизаторе выгодна тем, что позволяет по максимум задействовать работающий маршрутизатор, повесив на него максимальное количество функционала (интернет, NAT, DHCP и т.п.). DCHP позволит маршрутизатору автоматически настраивать на клиентах следующие основные параметры:

  • IP адрес
  • Основной шлюз
  • Маска подсети
  • DNS сервера
  • Имя домена
Читайте также:  Мастер по настройке шаринга

Ниже мы приводим для вас сразу несколько разных инструкций по настройке DHCP на оборудовании Cisco.

СОДЕРЖАНИЕ:

  • Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP
  • Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer
  • Листинг команд настройки маршрутизатора R1, на котором «поднят» DHCP сервер
  • Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети
  • Полезные команды настройке DHCP Cisco

Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP

Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer

В этой видео инструкции рассматривается процесс настройки централизованного DHCP сервера в программе Cisco Packet Tracer.

  • как настроить пулы динамических IP адресов для различных сегментов локальной сети,
  • как настроить рабочую станцию на получение динамического IP адреса,
  • как проверить наличие получения динамического IP адреса рабочей станцией.

Новые команды для настройки маршрутизатора для получения пула динамических IP адресов у централизованного DHCP сервера.

Для примера рассматривается роутер R1

Настройки производятся в режиме глобальной конфигурации:

R1(config)#interface fastEthernet 0/1 — заходим в настройки интерфейса к которому подключен компьютер получающий динамический IP адрес

R1(config-if)#ip helper-address 192.168.30.11 указывается IP адрес централизованного DHCP сервера.

Листинг команд настройки маршрутизатора R1, на котором «поднят» DHCP сервер, следующий:

R1(config)#interface Ethernet 0/1/0

R1(config-if)#ip address 172.33.56.1 255.255.255.0

R1(config)#ip dhcp excluded-address 172.33.56.1

R1(config)#ip dhcp excluded-address 172.33.56.254

R1(config)#ip dhcp pool R1SW6

R1(dhcp-config)#network 172.33.56.0 255.255.255.0

R1(config)#do sh ip prot

Routing Protocol is «bgp 1»

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

R1(config)#router bgp 1

R1(config-router)#do sh ip route

172.33.0.0/24 is subnetted, 1 subnets

C 172.33.56.0 is directly connected, Ethernet0/1/0

R1(config-router)#network 172.33.56.0 mask 255.255.255.0

Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети

Рассматривается настройка DHCP сервера на маршрутизаторе Cisco, показаны возможные причины неработоспособности сети, связанные с работой протоколов маршрутизации и варианты устранения данных неполадок.

Полезные команды настройке DHCP Cisco

  • Исключим из раздачи адрес 192.168.1.254 и адреса с 192.168.1.1 по 192.168.1.9

Router(config)# ip dhcp excluded-address 192.168.1.254

Router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9

Настройка DHCP сервера включает в себя определение пула адресов, которые будут раздаваться. Для создания пула используется команда ip dhcp pool [название_пула]. После этого необходимо ввести две обязательные команды – network [адрес_сети][маска/длина_префикса] для указания сети из которой будут раздаваться адреса и default-router[адрес_default_gateway] для указания шлюза по умолчанию (можно ввести до 8 адресов).

  • команда show ip dhcp binding показывает список всех IP адресов и сопоставленных с ними MAC адресов, которые были выданы DHCP сервером.
  • команда show ip dhcp server statistics покажет статистику DHCP сервера, включая информацию об отправленных и полученных DHCP сообщениях
  • Ретрансляция DHCP (DHCP RELAY)

Команда ip helper-address [адрес_DHCP-сервера] на маршрутизаторе в режиме конфигурации интерфейса укажет ему перенаправлять broadcast сообщения от DHCP клиентов уже в виде unicast к DHCP серверу, находящемуся в другой сети.

  • Настройка роутера DHCP клиента

Иногда роутер сам должен получить IP адрес по DHCP, например от интернет-провайдера. Для этого нужно в режиме конфигурации интерфейса ввести команду ip address dhcp, после чего интерфейс будет пытаться получить адрес от DHCP сервера.

Цены на сайте указаны с НДС.

При безналичном расчете цена не меняется.

Доставка по России, в Казахстан, в Беларусь. По Москве БЕСПЛАТНО!

Оперативный подбор оборудования и аналогов.

Источник

Adblock
detector