Меню

Cisco 2921 настройка с нуля



Маршрутизатор Cisco — начальная настройка

При первоначальной настройки маршрутизатор cisco необходимо подключить к COM порту компьютера, посредством специального консольного кабеля.

Кабель представляет собой с одной стороны разъём DB9 (female/мама) для подключения к COM порту компьютера, а с другой RJ-45 для подключения к консольному порту маршрутизатора (порт обведён в голубой цвет и имеет надпись Console, либо просто надпись Console на голубом фоне).

Консольный кабель Cisco

Консольные порты Cisco

Новые модели маршрутизаторов, например Cisco 2900 Series Integrated Services Routers (ISR), имеют как RJ-45 консольный порт, так и консольный порт mini-USB Type B.

Mini-USB порт позволяет подключаться к консоли через USB кабель, если вдруг в компьютере отсутствует COM порт. Если настройка роутера производится через USB кабель на компьютере с Microsoft Windows, на компьютер необходимо установить драйвер Cisco Microsoft Windows USB Device Driver.

Кабель Mini USB

Консольный порт USB имеет приоритет над RJ-45. При настройке одновременное использование консольных портов не допускается.

Для настройки устройства через консольный кабель на компьютере с Microsoft Windows можно использовать встроенную программу Hyper Terminal, для меня она не очень удобна, поэтому я использую Putty (возможно это просто дело привычки). В программе, будь то Putty, Hyper terminal или ещё какая-либо, необходимо настроить параметры порта (COM) следующим образом:

Скорость (бит/с): 9600

Стоповые биты: 1

Управление потоком: нет

Пример настройки в Putty:

Настройка COM порта в Putty

После чего, если маршрутизатор включен и соединен с компьютером консольным кабелем, в окне терминала (по нажатию на Enter) появится интерфейс командной строки. Так же здесь можно наблюдать и процесс загрузки устройства.

Можно приступать к настройке устройства.

Логин/пароль по умолчанию обычно либо cisco/cisco либо пустой пароль на вход в привилегированный режим.

Входим в привилегированный режим командой «enable»:

Очищаем существующую конфигурацию командой «erase startup-config»:

Router#
Router#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
Router#
*Mar 1 00:10:46.519: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Router#

Перезагружаем роутер командой «reload» и подтверждаем её:

Router#reload
Proceed with reload? [confirm]

*Mar 1 00:14:52.907: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload command.

Так как мы стерли конфигурационный файл startup-config, то после перезагрузки предлагается пройти мастер начальной настройки системы, в котором предлагается вести имя маршрутизатора, пароли для различных режимов, IP адрес на интерфейсе управления и прочее. Я обычно на запрос запуска мастера отвечаю: no , а все необходимые параметры ввожу вручную.

Пишем no и жмём Enter.

Переходим в режим глобального конфигурирования системы командой «configure terminal» (сперва не забываем перейти в привилегированный )

Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

Видно как изменилась строка приглашения на «Router(config)# » — означает, что мы находимся в глобальном режиме конфигурации системы

Задаём пароль на вход в привилегированный режим командой «enable secret»

Router(config)#enable secret 0 pass123
Router(config)#

0 — означает ввод пароля в не зашифрованном виде, но храниться будет он в шифрованном.

pass123 — сам пароль

Устанавливаем имя маршрутизатора командой «hostname»

Задаём имя домена командой «ip domain-name»

RTR1(config)#
RTR1(config)#ip domain-name test.ru
RTR1(config)#

Прописываем время, дату и часовой пояс. Задать время и дату можно просто в привилегированном режиме, не переходя в режим глобального конфигурирования системы, а вот часовой пояс только в режиме конфигурации.

Время и дата командой «clock set» (например 26 марта 2013 года, 19 часов 32 минуты 30 секунд):

RTR1#
RTR1#clock set 19:32:30 26 Mar 2013
RTR1#

Часовой пояс командой «clock timezone» (например смещение по UTC в +10 часов):

RTR1#
RTR1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RTR1(config)#
RTR1(config)#clock timezone YST 10
RTR1(config)#

Читайте также:  Настройка маршрутизаторов cisco список команд

Включаем аутентификацию и заводим пользователя.

RTR1(config)#
RTR1(config)#aaa new-model
RTR1(config)#aaa authentication login default local
RTR1(config)#

Команда «aaa new-model» — активирует возможность использования функций и команд для аутентификации, авторизации, аккаунтинга (AAA)

Команда «aaa authentication login default local» — включает аутентификацию при попытке сделать logon, и проверяет пользователя и пароль по локальной базе.

После ввода этих команд, нужно создать пользователя, иначе нельзя будет зайти на маршрутизатор ни по ssh/telnet, ни через консоль.

Создаём пользователя petya с паролем password123:

RTR1(config)#
RTR1(config)#username petya secret 0 password123
RTR1(config)#

Настраиваем сетевой интерфейс. Что бы настроить сетевой интерфейс, нужно перейти из режима глобального конфигурирования в режим конфигурирования интерфейса.

RTR1(config)#
RTR1(config)#interface fastEthernet 0/0
RTR1(config-if)#ip address 192.168.56.254 255.255.255.0
RTR1(config-if)#no shutdown
RTR1(config-if)#
RTR1(config-if)#
Mar 26 19:51:11.851: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
Mar 26 19:51:12.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RTR1(config-if)#
RTR1(config-if)#exit
RTR1(config)#

Команда «interface fastEthernet 0/0» — переводит в режим конфигурирования интерфейса. В данном случае у нас интерфейс называется «fastEthernet «, в зависимости от модели роутера, могут быть другие названия например ethernet или gigabitEthernet. Информацию о состоянии интерфейсов можно посмотреть командой «show interfaces»

Команда «ip address 192.168.56.254 255.255.255.0» — задаёт IP адрес и сетевую маску на интерфейсе

Команда «no shutdown» — включает интерфейс

Команда «exit» — производит выход из режима конфигурации интерфейса в глобальный режим конфигурации.

Разрешаем удаленный доступ к устройству по telnet или ssh. Не все версии IOS поддерживают ssh (необходима поддержка шифрования). Поэтому в некоторых случаях приходится настраивать удаленный доступ и для telnet. Для настройки ssh необходимо сперва сгенерировать ключи.

Генерируем ключи командой «crypto key generate rsa»:

RTR1(config)#
RTR1(config)#crypto key generate rsa
The name for the keys will be: RTR1.test.ru
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]:
% Generating 512 bit RSA keys . [OK]

RTR1(config)#
Mar 26 20:16:47.879: %SSH-5-ENABLED: SSH 1.5 has been enabled
RTR1(config)#

Как только сгенерировались ключи, в консоли вышло сообщение, что ssh включен. Кстати, для генерации ключей необходимо сперва задать имя домена и желательно выставить правильное время, что я уже сделал выше.

Разрешаем ssh и telnet на линиях виртуальных терминалов:

RTR1(config)#
RTR1(config)#line vty 0 4
RTR1(config-line)#transport input telnet ssh
RTR1(config-line)#exec-timeout 60
RTR1(config-line)#
RTR1(config-line)#exit
RTR1(config)#

Команда «line vty 0 4» — переводит в режим конфигурирования линий VTY с 0 по 4

Команда «transport input telnet ssh» — разрешает вход через telnet и ssh на терминалы vty

Команда «exec-timeout 60» — отключает от линии пользователя после 60 минут бездействия

команда «exit» — выход из режима конфигурировании линий в глобальный режим.

В данном случае разрешён удаленный доступ с любых IP адресов, что бы ограничить, необходимо создавать ACL и вешать их на линии.

Сохраняем конфигурацию. Всё, что мы сейчас настроили будет работать до первой перезагрузки. Что бы конфиг сохранился его нужно сохранить командой «copy running-config startup-config»:

RTR1(config)#exit
RTR1#copy running-config startup-config
Building configuration.
[OK]
RTR1#

Источник

Начальная настройка маршрутизатора Cisco. Доступ в Интернет.

Read the article BASIC CONFIGURATION OF THE CISCO ROUTER. ACCESS TO THE INTERNET in English

Рассмотрим схему подключения офиса к сети Интернет с помощью маршрутизатора Cisco. Для примера возьмем модель Cisco 881. Команды для настройки других маршрутизаторов (1841, 2800, 3825…) будут аналогичными Различия могут быть в настройке интерфейсов, вернее в их названиях и нумерации.

Читайте также:  Настройка редуктора longas airod

В схеме присутствуют:

  • канал в Интернет со статическим адресом
  • несколько компьютеров в локальной сети офиса
  • маршрутизатор
  • коммутатор, который используется для организации локальной сети офиса

Задача: обеспечить доступ компьютеров локальной сети в Интернет.

Шаг 0. Очистка конфигурации

Первое, с чего стоит начать настройку нового маршрутизатора – полностью очистить стартовую конфигурацию устройства. ( Выполнять только на новом или тестовом оборудовании! ) Для этого нужно подключиться с помощью специального кабеля к консольному порту маршрутизатора, зайти в командную строку и выполнить следующее:

Войти в привилегированный режим(#), возможно потребуется ввести логин/пароль.
router> enable
Удалить стартовую конфигурацию
router# write erase
/подтверждение/
Перезагрузить маршрутизатор
router# reload
/подтверждение/
После выполнения маршрутизатор должен перезагрузиться в течение 3ех минут, а при старте вывести запрос о начале базовой настройки. Следует отказаться.
Would you like to enter the basic configuration dialog (yes/no): no
В текущей конфигурации маршрутизатора будут только технологические строки по умолчанию, и можно приступать к основной настройке.

Шаг 1. Имя устройства

Задание имени маршрутизатора для удобства последующего администрирования выполняется командой hostname «название устройства»
router# conf t
router (config)# hostname R-DELTACONFIG
R-DELTACONFIG (config)#

Шаг 2. Настройка интерфейсов

Необходимо настроить 2 интерфейса: внешний и внутренний.
Через внешний интерфейс будет осуществляться связь с Интернет. На нем будут те ip адрес и маска сети, которые предоставил Интернет провайдер.
Внутренний интерфейс будет настроен для локальной сети 192.168.0.0 /24

Предположим, что оператор связи предоставил нам следующие адреса:

  • Сеть 200.150.100.0
  • Маска подсети 255.255.255.252 или /30
  • Шлюз по умолчанию 200.150.100.1

Настроим внешний интерфейс: зададим ip адрес и сетевую маску, и включим его командой no shut
R-DELTACONFIG#conf t
R-DELTACONFIG (config)#
interface Fa 4
ip address 200.150.100.2 255.255.255.252
no shutdown
После этого соединяем этот интерфейс маршрутизатора с портом оборудования провайдера при помощи прямого патч корда и далее проверяем его доступность командой ping.

Сначала собственный интерфейс
R-DELTACONFIG# ping 200.150.100.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.150.100.2, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 1/1/4 ms
Затем соседний адрес — шлюз провайдера
R-DELTACONFIG# ping 200.150.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.150.100.1, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 2/4/10 ms
Убедившись в доступности шлюза Провайдера, переходим к настройке внутреннего интерфейса.

В локальной сети будет использоваться следующая адресация

  • Сеть 192.168.0.0
  • Маска подсети 255.255.255.0
  • Внутренний адрес маршрутизатора, который выполняет роль шлюза в Интернет для всех хостов в сети, 192.168.0.1
  • Диапазон внутренних адресов сети (пользователи, принтеры, серверы и.т.д.) советую начинать с адреса 192.168.0.5
  • Максимально возможный доступный для использования адрес в этой сети будет 192.168.0.254
  • Адреса с 192.168.0.2 до 192.168.0.4 оставим про запас для непредвиденных технологических нужд

Для настройки внутреннего интерфейса локальной сети следует зайти в режим конфигурирования виртуального интерфейса Vlan 1, задать на нем ip адрес и соотнести ему один из физических интерфейсов маршрутизатора (Fa 0).
R-DELTACONFIG#conf t
interface Vlan 1
Ip address 192.168.0.1 255.255.255.0
no shutdown
Выбираем физический интерфейс маршрутизатора и соотносим его с виртуальным Vlan
interface Fa 0
switchport access vlan 1
no shutdown
Для наглядности:

ip address => interface Vlan X => interface Fastethernet Y
Ip адрес присваивается виртуальному интерфейсу Vlan X, а он привязывается к физическому интерфейсу Fastethernet Y.

Интерфейс маршрутизатора Fa 0 нужно соединить с коммутатором, где располагаются рабочие станции локальной сети или напрямую с рабочей станцией администратора. После этого проверить доступность этого интерфейса маршрутизатора с помощью ping из командной строки.

Шаг 3 Настройка удаленного доступа к маршрутизатору

Получить доступ к консоли маршрутизатора можно не только с помощью консольного кабеля, но и удаленно с помощью протоколов Telnet(данные передаются в открытом виде) или SSH(защищенное соединение).
Рассмотрим настройку безопасного подключения.
Включаем протокол SSH 2 версии и задаем произвольное имя домена
R-DELTACONFIG (config)#
ip ssh ver 2
ip domain-name xxx.ru
Генерируем ключи rsa, необходимые для подключения. При запросе указываем 1024.
crypto key generate rsa
How many bits in the modulus [512]: 1024
Задаем имя пользователя с правами администратора и его пароль (*****)
username admin privilege 15 secret 0 *****
Включаем авторизацию через локальную базу устройства (тот пользователь, которого создали строчкой выше)
line vty 0 4
login local
Задаем пароль на привилегированный режим
enable secret 0 *****
После этого при помощи специальной программы, поддерживающей протокол SSH можно зайти в командную строку маршрутизатора удаленно с любой из рабочих станций локальной сети. При авторизации следует ввести логин и пароль, которые были задан. Подробнее про доступ на устройство по протоколу SSH написано в этой статье.

Читайте также:  Strong srt 8500 подключение и настройка

Шаг 4. Шлюз по умолчанию

Для маршрутизации пакетов в сеть Интернет на устройстве необходимо указать шлюз по умолчанию(default gateway).
R-DELTACONFIG (config)#
ip route 0.0.0.0 0.0.0.0 200.150.100.1
После этого можно проверить не только доступность оборудования провайдера, но и полностью канала в Интернет. Для этого необходимо запустить ping до любого адреса во внешней сети в цифровой форме(DNS для локальной сети лучше настраивать после настройки маршрутизатора). Для примера возьмем адрес лидера на рынке ping – www.yandex.ru (93.158.134.3)
R-DELTACONFIG#ping 93.158.134.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 93.158.134.3, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 1/5/10 ms

Важно!
Обратите внимание, что на данный момент ping внешних адресов работает только(!) будучи запущенным из консоли управления маршрутизатором. Рабочие станции локальной сети все еще не имеют доступа в Интернет.

Шаг 5 Настройка трансляции адресов (NAT)

Для доступа в Интернет из локальной сети необходимо динамически транслировать все внутренние адреса в определенный внешний ip адрес. В нашем случае, так как провайдер предоставляет только один внешний адрес 200.150.100.2 (определяется маской подсети /30 в условиях примера), то все адреса локальной сети должны транслироваться в него.
Указываем список внутренних адресов, которые будем транслировать во внешний адрес.
R-DELTACONFIG (config)#
ip access-list standard ACL_NAT
permit 192.168.0.0 0.0.0.255
Указываем внутренний интерфейс для процедуры трансляции
Interface Vlan 1
ip nat inside
Указываем внешний интерфейс для процедуры трансляции
Interface Fa 4
ip nat outside
Создаем правило трансляции (NAT)
ip nat inside source list ACL_NAT interface fa4
В результате должен появиться доступ с любой рабочей станции локальной сети в Интернет при условии, что шлюзом по умолчанию указан внутренний ip адрес маршрутизатора (192.168.0.1). Проверить можно с помощью команды ping до адреса в Интернет из командной строки. Желательно, чтобы проверяемый адрес был в цифровом виде, чтобы исключить потенциальные проблемы с DNS именами.

Важно!
В указанном примере меняется собственный адрес источника. Если в процессе работы необходимо транслировать адрес назначения — пускать траффик на вымышленный адрес, чтобы попасть на некий настоящий, то прочитайте статью ip nat outside.

Важно!
Не стоит оставлять полный доступ в Интернет со всех адресов локальной сети. Советую после проверки работоспособности соединения для безопасности ограничить доступ в Интернет и разрешить его только с конкретных адресов — например с прокси сервера и рабочих станций администратора и/или директора. О том как это сделать можно прочитать в статье «немного об access lists«.

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
R-DELTACONFIG# write
Building configuration.
[OK]

Источник

Adblock
detector